freebsd-ports/x11/sddm/files/patch-CMakeLists.txt
Adriaan de Groot 2d4534668d Update x11/sddm to 0.17.
This is still one minor release behind, but a big update relative to
the previous version. Thanks to tijl@ for the patches, dbn@ for
initial testing.

PR:		228116
Submitted by:	tijl
2018-09-08 10:28:11 +00:00

16 lines
557 B
Text

1) On FreeBSD X is normally started on VT9.
2) The shutdown command uses '-p' and not '-P' on FreeBSD.
--- CMakeLists.txt.orig 2017-12-05 16:00:16 UTC
+++ CMakeLists.txt
@@ -168,8 +168,8 @@ add_feature_info("elogind" ELOGIND_FOUND "elogind supp
# Default behaviour if neither systemd nor elogind is used
if (NOT ELOGIND_FOUND AND NOT SYSTEMD_FOUND)
- set(MINIMUM_VT 7)
- set(HALT_COMMAND "/sbin/shutdown -h -P now")
+ set(MINIMUM_VT 9)
+ set(HALT_COMMAND "/sbin/shutdown -p now")
set(REBOOT_COMMAND "/sbin/shutdown -r now")
endif()