freebsd-ports/devel/libtool14/files/patch-af
Ade Lovett b2fd75e438 libtool uber-patch
* kill devel/libtool and move to devel/libtool13, upgrading to 1.3.5
* upgrade repo-copied devel/libtool14 to 1.4.3
* break out libltdl into its own separate port
* move to version-numbered binaries/scripts (ie: there is *no* 'libtool'
  any more -- USE_LIBTOOL and USE_LIBTOOL_VER are your friends)

Approved by:	portmgr (kris) - for the bsd.port.mk hooks
Tested by:	bento 4-exp builds (repeatedly)
2003-06-26 22:58:32 +00:00

37 lines
1.4 KiB
Text

--- libltdl/Makefile.in.orig Wed Oct 23 02:26:07 2002
+++ libltdl/Makefile.in Mon Feb 17 02:06:58 2003
@@ -342,3 +342,3 @@
mkdir $(distdir)
- -chmod 777 $(distdir)
+ -chmod 555 $(distdir)
@for file in $(DISTFILES); do \
@@ -346,9 +346,8 @@
if test -d $$d/$$file; then \
- cp -pr $$d/$$file $(distdir)/$$file; \
+ echo no copy dir $$d/$$file; \
else \
- test -f $(distdir)/$$file \
- || ln $$d/$$file $(distdir)/$$file 2> /dev/null \
- || cp -p $$d/$$file $(distdir)/$$file || :; \
+ install -c -o root -g wheel -m 444 $$d/$$file $(distdir)/$$file; \
fi; \
done
+ -chmod a+x $(distdir)/configure
info-am:
@@ -452,4 +451,4 @@
local-install-files: $(DISTFILES)
- -rm -rf $(DESTDIR)$(datadir)/libtool/libltdl
- $(mkinstalldirs) $(DESTDIR)$(datadir)/libtool/libltdl
+ -rm -rf $(DESTDIR)$(datadir)/libtool14/libltdl
+ $(mkinstalldirs) $(DESTDIR)$(datadir)/libtool14/libltdl
@for file in $(DISTFILES); do \
@@ -457,6 +456,6 @@
if test -d $$d/$$file; then \
- cp -r $$d/$$file $(DESTDIR)$(datadir)/libtool/libltdl/$$file; \
+ cp -r $$d/$$file $(DESTDIR)$(datadir)/libtool14/libltdl/$$file; \
else \
- test -f $(DESTDIR)$(datadir)/libtool/libltdl/$$file \
- || cp $$d/$$file $(DESTDIR)$(datadir)/libtool/libltdl/$$file || :; \
+ test -f $(DESTDIR)$(datadir)/libtool14/libltdl/$$file \
+ || cp $$d/$$file $(DESTDIR)$(datadir)/libtool14/libltdl/$$file || :; \
fi; \