ECWolf is an advanced source port for Wolfenstein 3D, Spear of Destiny, and Super 3D Noah's Ark based off of the Wolf4SDL code base. ECWolf pulls a substantial amount of code from ZDoom and aims to provide a wide array of mod editing capabilities without the need to modify the source code. Most importantly you will no longer need to replace entire data sets. With ECWolf you could for example add a weapon without needing to distribute every sprite in the game along with it. Mods will be neatly packaged into a single file just like they are for Doom. WWW: https://maniacsvault.net/ecwolf PR: 230848 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl>
24 lines
1.1 KiB
Text
24 lines
1.1 KiB
Text
--- src/CMakeLists.txt.orig 2019-01-29 16:31:24 UTC
|
|
+++ src/CMakeLists.txt
|
|
@@ -40,9 +40,9 @@ else(GPL)
|
|
set(EXTRA_LIBRARIES)
|
|
endif(GPL)
|
|
|
|
-find_package(SDL REQUIRED)
|
|
-find_package(SDL_mixer REQUIRED)
|
|
-include_directories(${SDLMIXER_INCLUDE_DIR} ${SDL_INCLUDE_DIR} ${ZLIB_INCLUDE_DIR} ${BZIP2_INCLUDE_DIR} ${JPEG_INCLUDE_DIR})
|
|
+pkg_search_module(SDL REQUIRED sdl sdl)
|
|
+pkg_search_module(SDLMIXER REQUIRED SDL_mixer)
|
|
+include_directories(${SDLMIXER_INCLUDE_DIRS} ${SDL_INCLUDE_DIRS}/SDL ${ZLIB_INCLUDE_DIR} ${BZIP2_INCLUDE_DIR} ${JPEG_INCLUDE_DIR})
|
|
|
|
check_function_exists(stricmp STRICMP_EXISTS)
|
|
check_function_exists(strnicmp STRNICMP_EXISTS)
|
|
@@ -320,7 +320,7 @@ else(NOT ANDROID)
|
|
endif(NOT ANDROID)
|
|
|
|
add_dependencies(ecwolf lzma gdtoa revision_check)
|
|
-target_link_libraries(ecwolf ${EXTRA_LIBRARIES} ${SDL_LIBRARY} ${SDLMIXER_LIBRARY} ${ZLIB_LIBRARY} ${BZIP2_LIBRARIES} ${JPEG_LIBRARIES} lzma gdtoa)
|
|
+target_link_libraries(ecwolf ${EXTRA_LIBRARIES} ${SDL_LIBRARIES} ${SDLMIXER_LIBRARIES} ${ZLIB_LIBRARY} ${BZIP2_LIBRARIES} ${JPEG_LIBRARIES} lzma gdtoa)
|
|
set_target_properties(ecwolf PROPERTIES RUNTIME_OUTPUT_DIRECTORY ${OUTPUT_DIR})
|
|
|
|
# Install
|