ecbb96a533
o Update URL in MASTER_SITES to current address o Update MAINTAINER o Remove post-patch target as it is not needed - Use LDFLAGS instead of the non-standard variable ADDITIONALLINKOPTIONS. - Replace "${REINPLACE_CMD} 's,log2,gfan_log2,g'" by appropriate patch files as the command triggers multiple warnings. log2 is a macro defined in src/log.h. The name of this macro is in conflict with the function log2 from math.h. To avoid errors when compiling the code, the above renaming is necessary. Furthermore, PHB 4.4.3 strongly suggests using patch files instead of REINPLACE_CMD for static content. o Sort pkg-plist alphabetically as required by PHB 3.2.2 o Shorten pkg-descr and make it less technical PR: 250879 Submitted by: Moritz Schmitt (maintainer)
11 lines
550 B
C++
11 lines
550 B
C++
--- src/app_tropicalintersection.cpp.orig 2017-06-20 14:47:37 UTC
|
|
+++ src/app_tropicalintersection.cpp
|
|
@@ -37,7 +37,7 @@ class SymmetricTargetTropicalBasisTester : public Symm
|
|
bool process(ConeTraverser &traverser)
|
|
{
|
|
IntegerVector w=traverser.refToPolyhedralCone().getRelativeInteriorPoint();
|
|
- log2 AsciiPrinter(Stderr) << "Testing weight vector:\n"<<w<<"\n";
|
|
+ gfan_log2 AsciiPrinter(Stderr) << "Testing weight vector:\n"<<w<<"\n";
|
|
WeightReverseLexicographicTermOrder T(w);
|
|
buchberger(&g,T);
|
|
PolynomialSet temp=initialForms(g,w);
|