da35507d98
- Move some vars around to make portlint happy - Use MUTT_LITE instead of LITE - Fetch deepif and date-contitional from remote locations - Reword COMMENT - Bring back remote patch versions incase mutt version and patch versions arn't in sync - Remove date_conditional patch pulled in remotely - Add two new sidebar samples - convert patch-* patches to makepatch patches - Greeting patch 1.7.1 now PATCHFILE - make makesum will pull all optional dist/patchfiles PR: 213431 Submitted by: maintainer (dereks lifeofadishwasher com)
94 lines
3.8 KiB
Text
94 lines
3.8 KiB
Text
--- INSTALL.orig 2016-10-08 19:30:21 UTC
|
||
+++ INSTALL
|
||
@@ -228,13 +228,13 @@ If you decide to use your system's iconv
|
||
need to tell mutt about implementation-defined names for some
|
||
character sets. Sample configuration files for various systems can
|
||
be found in the directory contrib/iconv/ in this source
|
||
-distribution, and will be installed in the samples/iconv directory
|
||
+distribution, and will be installed in the share/examples/mutt/iconv directory
|
||
as part of mutt's documentation.
|
||
|
||
In order to use these sample configuration files, just put a line
|
||
like
|
||
|
||
- source /usr/local/doc/mutt/samples/iconv/iconv.osf1-4.0d.rc
|
||
+ source /usr/local/share/examples/mutt/iconv/iconv.osf1-4.0d.rc
|
||
|
||
into your system's global Muttrc, which normally resides in /etc or
|
||
/usr/local/etc.
|
||
--- contrib/Makefile.am.orig 2016-10-08 19:30:21 UTC
|
||
+++ contrib/Makefile.am
|
||
@@ -1,6 +1,7 @@
|
||
# $Id$
|
||
|
||
subdir = contrib
|
||
+samplesdir = @samplesdir@
|
||
|
||
SAMPLES = Mush.rc Pine.rc gpg.rc pgp2.rc pgp5.rc pgp6.rc Tin.rc \
|
||
sample.mailcap sample.muttrc sample.muttrc-sidebar sample.muttrc-tlr \
|
||
@@ -14,12 +15,12 @@ EXTRA_DIST = language.txt language50.txt
|
||
iconv/make.sh
|
||
|
||
install-data-local:
|
||
- $(MKDIR_P) $(DESTDIR)$(docdir)/samples $(DESTDIR)$(docdir)/samples/iconv
|
||
+ $(MKDIR_P) $(DESTDIR)$(samplesdir) $(DESTDIR)$(samplesdir)/iconv
|
||
for f in $(SAMPLES) ; do \
|
||
- $(INSTALL) -m 644 $(srcdir)/$$f $(DESTDIR)$(docdir)/samples ; \
|
||
+ $(INSTALL) -m 644 $(srcdir)/$$f $(DESTDIR)$(samplesdir) ; \
|
||
done
|
||
for f in $(srcdir)/iconv/*.rc ; do \
|
||
- $(INSTALL) -m 644 $$f $(DESTDIR)$(docdir)/samples/iconv ; \
|
||
+ $(INSTALL) -m 644 $$f $(DESTDIR)$(samplesdir)/iconv ; \
|
||
done
|
||
|
||
uninstall-local:
|
||
--- doc/manual.txt.orig 2016-10-08 19:55:06 UTC
|
||
+++ doc/manual.txt
|
||
@@ -8073,8 +8073,8 @@ set imap_authenticators="gssapi:cram-md5
|
||
|
||
For examples on how to configure these formats for the various versions
|
||
of PGP which are floating around, see the pgp and gpg sample
|
||
- configuration files in the samples/ subdirectory which has been
|
||
- installed on your system alongside the documentation. (PGP only)
|
||
+ configuration files in the share/examples/mutt/ subdirectory which has
|
||
+ been installed on your system alongside the documentation. (PGP only)
|
||
|
||
3.166. pgp_decrypt_command
|
||
|
||
@@ -9332,8 +9332,8 @@ set sidebar_delim_chars='.'
|
||
or "-CAfile [1766]$$ssmmiimmee__ccaa__llooccaattiioonn".
|
||
|
||
For examples on how to configure these formats, see the smime.rc in the
|
||
- samples/ subdirectory which has been installed on your system alongside
|
||
- the documentation. (S/MIME only)
|
||
+ share/examples/mutt/ subdirectory which has been installed on your system
|
||
+ alongside the documentation. (S/MIME only)
|
||
|
||
3.271. smime_decrypt_use_default_key
|
||
|
||
--- init.h.orig 2016-10-08 19:35:50 UTC
|
||
+++ init.h
|
||
@@ -1814,9 +1814,8 @@ struct option_t MuttVars[] = {
|
||
** .pp
|
||
** For examples on how to configure these formats for the various versions
|
||
** of PGP which are floating around, see the pgp and gpg sample configuration files in
|
||
- ** the \fCsamples/\fP subdirectory which has been installed on your system
|
||
- ** alongside the documentation.
|
||
- ** (PGP only)
|
||
+ ** the \fCshare/examples/mutt/\fP subdirectory which has been installed on
|
||
+ ** your system. (PGP only)
|
||
*/
|
||
{ "pgp_decrypt_command", DT_STR, R_NONE, UL &PgpDecryptCommand, 0},
|
||
/*
|
||
@@ -2942,9 +2941,8 @@ struct option_t MuttVars[] = {
|
||
** .de
|
||
** .pp
|
||
** For examples on how to configure these formats, see the \fCsmime.rc\fP in
|
||
- ** the \fCsamples/\fP subdirectory which has been installed on your system
|
||
- ** alongside the documentation.
|
||
- ** (S/MIME only)
|
||
+ ** the \fCshare/examples/mutt/\fP subdirectory which has been installed on
|
||
+ ** your system. (S/MIME only)
|
||
*/
|
||
{ "smime_decrypt_use_default_key", DT_BOOL, R_NONE, OPTSDEFAULTDECRYPTKEY, 1 },
|
||
/*
|