ae179afb91
We switched FreeBSD-5.x port to libkse as default threading library before releasing of patchset 6, but users who has most of stuff linked against libc_r and attempted to use jdk linked against libkse got into local hell of threading libraries mix. So, rollback to libc_r by default and add PTHREAD_LIBS support for this port. IMPORTANT: In order to use libkse as threading library for jdk14 you have to use rtld's libmap feature or recompile your ports stuff (like mozilla) with libkse. NOTE: libkse still has issues with java debug support, so if you're going to use debuging (JVMDI) stuff - leave with libc_r for now. 2. Disable IPv6 support by default. Unfortunatelly due to security reasons IPv4-to-IPv6 addresses mapping is disabled by default in FreeBSD-5.x, so those who would like to use Java Networking stuff had to manually enable it. To make jdk14 port more user-friendly IPv6 is disabled now on compile time. Those who need this stuff enabled have to use WITH_IPV6 compile time option. 3. Add MINIMAL compile option. If this option is used to build jdk14 port then plugin, javaws and demos stuff will not be installed and/or packaged. Also (as noted in [5]) X11 runtime dependancy will not be registered into built package. 4. Strip runtime depends of jdk14 port. There's no need to require open-motif to be runtime depends since libXm is staticly linked into libawt.so. 5. Make X11 runtime dependancy conditional (via urwfonts) in !WITHOUT_PLUGIN case only. This should affect only prebuilt package users: there's no need to install X11 libraries if you're going to use non-GUI stuff only (i.e. tomcat or jboss) 6. Add ${LOCALBASE}/lib to the deafult search path for JNI libraries. 7. Bump PORTVERSION Reported by: many [1] Submitted by: glewis [6] Requested by: marcus [6]
46 lines
909 B
Text
46 lines
909 B
Text
$FreeBSD$
|
|
|
|
--- ../../deploy/make/Makefile.orig Tue Jan 27 18:54:56 2004
|
|
+++ ../../deploy/make/Makefile Tue Jan 27 18:58:08 2004
|
|
@@ -24,17 +24,29 @@
|
|
DEPLOY_TOPDIR=..
|
|
include $(BUILDDIR)/common/Defs.gmk
|
|
|
|
+ifdef NO_PLUGIN
|
|
+BUILD_PLUGIN= false
|
|
+else
|
|
+BUILD_PLUGIN= true
|
|
+endif
|
|
+
|
|
+ifdef NO_JAVAWS
|
|
+BUILD_JAVAWS= false
|
|
+else
|
|
+BUILD_JAVAWS= true
|
|
+endif
|
|
+
|
|
all::
|
|
@$(ECHO) "$(PLATFORM) $(ARCH) $(RELEASE) deploy build started: $(shell $(DATE) '+%y-%m-%d %H:%M')"
|
|
|
|
-BUILD_PLUGIN = true
|
|
-
|
|
#
|
|
# Core.
|
|
#
|
|
JAVAWS_SUBDIR = javaws
|
|
PLUGIN_SUBDIR = plugin
|
|
+ifeq ($(BUILD_JAVAWS), true)
|
|
SUBDIRS = $(JAVAWS_SUBDIR)
|
|
+endif
|
|
ifeq ($(BUILD_PLUGIN), true)
|
|
SUBDIR += $(PLUGIN_SUBDIR)
|
|
endif
|
|
@@ -47,7 +59,9 @@
|
|
done
|
|
|
|
javaws-all: sanity-javaws
|
|
+ ifeq ($(BUILD_JAVAWS), true)
|
|
$(CD) $(BUILDDIR)/javaws ; $(MAKE) installer-int dev-all doc aubundle
|
|
+ endif
|
|
|
|
plugin-all: sanity-plugin
|
|
ifeq ($(BUILD_PLUGIN), true)
|