freebsd-ports/devel/cocktail/files/patch-ell-src-Makefile
Edwin Groothuis 8937ed4066 [PORT UPGRADE] devel/cocktail corrected for 64bits compilation
The orignal port only ran on i386, since there were some
	64bit conversion problems. The included tar file replaces
	the compete devel/cocktail tree currently in the ports tree.

(lots of patches!)

PR:		ports/71940
Submitted by:	Willem Jan Withagen <wjw@withagen.nl>
2004-12-15 04:05:34 +00:00

42 lines
1,006 B
Text

--- /usr/ports/devel/cocktail/work/cocktail-9309//./ell/src/Makefile Tue Feb 15 14:22:52 1994
+++ ./ell/src/Makefile Thu Aug 5 18:48:54 2004
@@ -31,7 +31,7 @@
ell: $(GENDEFS) $(GENIMPS) ell_boot
ell_boot: $(DEFS) $(IMPS) ell.mi
- rm -f ell
+ -rm -f ell
echo p ell | mc -d ../../common/src -d ../../reuse/src
install: ell ell.sh ErrorTab $(LIB)/ell
@@ -48,13 +48,13 @@
sh -c "if test ! -d $(LIB)/ell; then mkdir -p $(LIB)/ell; else true; fi"
Scanner.mi Scanner.md: ell.rex
- rex -d ell.rex;
+ $(REX) -d ell.rex;
Parser.mi Parser.md: ell.ell
- ell -di ell.ell;
+ $(ELL) -di ell.ell;
Tree.mi Tree.md: ell.ast
- cg -dimR ell.ast;
+ $(CG) -dimR ell.ast;
Semantics.md Semantics.mi: Sem.estra
estra $(ESTRA) Sem.estra;
@@ -75,10 +75,11 @@
cd ../m2c; rm -f *.m[id]
clean:
- rm -f core ERRORS LISTING *.[dimor] ell convert *.bak
+ -rm -f $(STDCLEAN)
+ -rm -f ERRORS LISTING *.[dimor] ell convert *.bak
CLEAN: clean
- rm -f $(SOURCES)
+ -rm -f $(SOURCES)
.SUFFIXES: .MI .mi