freebsd-ports/emulators/pcem/files/patch-configure.ac
Kurt Jaeger d58a92fe1a New port: emulators/pcem: PC-Compatible low-level emulator striving for accuracy
A very accurate (and not very fast) PC and PC-compatible emulator.
Support currently ranges from the original IBM PC to Socket 7 motherboards.
It also supports a wide range of peripherals, including Voodoo Graphics!

WWW: https://www.pcem-emulator.co.uk

PR:		237376
Submitted by:	Salvador Pardinas <darkfm@vera.com.uy>
Reviewed by:	tobik
2019-05-06 03:13:22 +00:00

32 lines
951 B
Text

--- configure.ac.orig 2019-04-17 19:37:48 UTC
+++ configure.ac
@@ -64,6 +64,10 @@ case "${host_cpu}" in
CPU=x86_64
AC_MSG_RESULT(${host_cpu})
;;
+ amd64)
+ CPU=x86_64
+ AC_MSG_RESULT(${host_cpu})
+ ;;
*)
AC_MSG_ERROR([Unsupported CPU.])
;;
@@ -149,6 +153,18 @@ case "$host" in
[echo "You need to install the OpenAL library."
exit -1])
build_linux="yes"
+ ;;
+ *-*-freebsd*)
+ CFLAGS="$CFLAGS -I/usr/local/include"
+ CXXFLAGS="$CXXFLAGS -I/usr/local/include"
+ LDFLAGS="$LDFLAGS -L/usr/local/lib"
+ AC_CHECK_LIB([GL], [glGetError], [], \
+ [echo "You need to install the OpenGL library."
+ exit -1])
+ AC_CHECK_LIB([openal], [alGetError], [], \
+ [echo "You need to install the OpenAL library."
+ exit -1])
+ build_other="yes"
;;
*)
AC_CHECK_LIB([GL], [glGetError], [], \