eeda7dda12
make way for a port of NetHack 3.6.0. . Add a note to updating on how to preserve save and bones files. PR: 205255 Submitted by: groot@kde.org (partially)
41 lines
1.6 KiB
Text
41 lines
1.6 KiB
Text
--- sys/unix/Makefile.doc.orig 2003-12-07 15:39:13.000000000 -0800
|
|
+++ sys/unix/Makefile.doc 2015-12-27 14:11:19.343677000 -0800
|
|
@@ -41,15 +41,15 @@
|
|
|
|
|
|
GAME = nethack
|
|
-MANDIR = /usr/man/man6
|
|
+MANDIR = ${PREFIX}/man/man
|
|
MANEXT = 6
|
|
|
|
# manual installation for most BSD-style systems
|
|
-GAMEMANCREATE = cp nethack.6
|
|
-LEVMANCREATE = cp lev_comp.6
|
|
-DGNMANCREATE = cp dgn_comp.6
|
|
-RCVRMANCREATE = cp recover.6
|
|
-DLBMANCREATE = cp dlb.6
|
|
+GAMEMANCREATE = ${BSD_INSTALL_MAN} nethack.6
|
|
+LEVMANCREATE = ${BSD_INSTALL_MAN} lev_comp.6
|
|
+DGNMANCREATE = ${BSD_INSTALL_MAN} dgn_comp.6
|
|
+RCVRMANCREATE = ${BSD_INSTALL_MAN} recover.6
|
|
+DLBMANCREATE = ${BSD_INSTALL_MAN} dlb.6
|
|
# manual installation for most SYSV-style systems
|
|
# GAMEMANCREATE = nroff -man nethack.6 >
|
|
# LEVMANCREATE = nroff -man lev_comp.6 >
|
|
@@ -58,11 +58,11 @@
|
|
# DLBMANCREATE = nroff -man dlb.6 >
|
|
|
|
manpages:
|
|
- -$(GAMEMANCREATE) $(MANDIR)/$(GAME).$(MANEXT)
|
|
- -$(LEVMANCREATE) $(MANDIR)/lev_comp.$(MANEXT)
|
|
- -$(DGNMANCREATE) $(MANDIR)/dgn_comp.$(MANEXT)
|
|
- -$(RCVRMANCREATE) $(MANDIR)/recover.$(MANEXT)
|
|
- -$(DLBMANCREATE) $(MANDIR)/dlb.$(MANEXT)
|
|
+ -$(GAMEMANCREATE) ${DESTDIR}$(MANDIR)$(MANEXT)/%%HACKNAME%%.$(MANEXT)
|
|
+ -$(LEVMANCREATE) ${DESTDIR}$(MANDIR)$(MANEXT)/lev_comp%%HACKEXT%%.$(MANEXT)
|
|
+ -$(DGNMANCREATE) ${DESTDIR}$(MANDIR)$(MANEXT)/dgn_comp%%HACKEXT%%.$(MANEXT)
|
|
+ -$(RCVRMANCREATE) ${DESTDIR}$(MANDIR)$(MANEXT)/recover%%HACKEXT%%.$(MANEXT)
|
|
+ -$(DLBMANCREATE) ${DESTDIR}$(MANDIR)$(MANEXT)/dlb%%HACKEXT%%.$(MANEXT)
|
|
|
|
# manual creation for distribution
|
|
DISTRIB = Guidebook.txt nethack.txt lev_comp.txt dgn_comp.txt recover.txt dlb.txt
|