freebsd-ports/net/isc-dhcp40-server/files/patch-common::parse.c
Dag-Erling Smørgrav b77059fee2 Mega-update from maintainer:
isc-dhcp3-client/pkg-message
 	updated

 isc-dhcp3-devel/pkg-plist
 	updated from PR#61620

 isc-dhcp3-relay/pkg-message
 	rewritten to reflect rcNG change
 isc-dhcp3-relay/pkg-plist
 	etc/rc.isc-dhcrelay.conf deleted
 	etc/rc.d/isc-dhcrelay.sh.sample renamed to etc/rc.d/isc-dhcrelay.sh

 isc-dhcp3-server/Makefile
 	PORTREVISION bumped
 	USE_RC_SUBR added
 	*_SUB added
 	pre-everything added (WITHOUT_INTERFACE_POLLING cond added)
 	patch-scripts and patch-pkgmessage (! -devel cond) updated
 	patch-site-conf and patch-rc-scripts added
 	install-startup-files now install etc/rc.d/isc-dhcpd.sh
 	 instead of etc/rc.d/isc-dhcpd.sh.sample
 	display-message updated (! -devel cond)
 isc-dhcp3-server/pkg-message
 	rewritten to reflect rcNG change
 isc-dhcp3-server/pkg-plist
 	etc/rc.isc-dhcpd.conf deleted
 	etc/rc.d/isc-dhcpd.sh.sample renamed to etc/rc.d/isc-dhcpd.sh
 isc-dhcp3-server/files/isc-dhcpd.sh.sample
 isc-dhcp3-server/files/isc-dhcrelay.sh.sample
 	both converted to rcNG
 isc-dhcp3-server/files/patch-freebsd
 	synced w/ -current
 isc-dhcp3-server/files/patch-site.conf
 	CLIENT_PATH added
 	CFLAGS synced w/ -current
 isc-dhcp3-server/patch-client::clparse.c
 isc-dhcp3-server/patch-client::dhclient.8
 	new files synced w/ -current
 isc-dhcp3-server/patch-client::dhclient.c
 	new file synced w/ -current (-DENABLE_POLLING_MODE)
 isc-dhcp3-server/patch-client::dhclient.conf
 	new file
 isc-dhcp3-server/patch-common::dhcp-options.5
 	new file synced w/ -current
 isc-dhcp3-server/patch-common::discover.c
 	new file from PR#61011
 isc-dhcp3-server/patch-common::dispatch.c
 	new file synced w/ -current (-DENABLE_POLLING_MODE)
 isc-dhcp3-server/files/patch-common::parse.c
	fix time_t issues on little-endian 64-bit platforms
 isc-dhcp3-server/patch-dst::Makefile.dist
 	new file from PR#61620
 isc-dhcp3-server/patch-includes::cf::freebsd.h
 	new file synced w/ -current (-DRESCUE unused right now)
 isc-dhcp3-server/patch-includes::dhcpd.h
 	new file synced w/ -current (-DENABLE_POLLING_MODE)
 isc-dhcp3-server/files/rc.isc-dhcpd.conf.sample
 isc-dhcp3-server/files/rc.isc-dhcrelay.conf.sample
 	deleted files

PR:		57943, 61011, 61620
Submitted by:	sec@42.org, andy@fud.org.nz, kaa@in-line.ru, des, ru
2004-03-16 20:31:15 +00:00

22 lines
585 B
C

--- common/parse.c.orig 2 Sep 2003 11:01:23 -0000
+++ common/parse.c 22 Feb 2004 10:44:52 -0000
@@ -414,6 +414,7 @@
{
const char *val;
enum dhcp_token token;
+ int32_t num;
token = next_token (&val, (unsigned *)0, cfile);
if (token != NUMBER) {
@@ -421,9 +422,9 @@
skip_to_semi (cfile);
return;
}
- convert_num (cfile, (unsigned char *)timep, val, 10, 32);
+ convert_num (cfile, (unsigned char *)&num, val, 10, 32);
/* Unswap the number - convert_num returns stuff in NBO. */
- *timep = ntohl (*timep); /* XXX */
+ *timep = ntohl (num);
parse_semi (cfile);
}