freebsd-ports/games/stonesoup/files/patch-Makefile
Pawel Pekala 87a9e4c1e7 - Update to version 0.13.0
- Allow staging
- Fix build on CURRENT

PR:		ports/182913
Submitted by:	maintainer
2013-10-30 21:54:57 +00:00

102 lines
3.1 KiB
Text

--- ./Makefile.orig 2013-09-30 20:32:00.000000000 +0200
+++ ./Makefile 2013-10-11 22:07:08.167887693 +0200
@@ -69,7 +69,7 @@
# ask for a package with convenience libraries instead -- we'll try to provide
# them somewhere in the near future.
-GAME = crawl
+GAME = stonesoup
# Disable GNU Make implicit rules and variables. Leaving them enabled will slow
# down MinGW and Cygwin builds by a very VERY noticeable degree. Besides, we have
@@ -101,7 +101,7 @@
#
-CFOTHERS := -pipe $(EXTERNAL_FLAGS)
+CFOTHERS := $(CFLAGS)
CFWARN := -Wall -Wformat-security
CFWARN_L := -Wundef
@@ -118,8 +118,6 @@
#
AR = ar
RANLIB = ranlib
-CC = $(GCC)
-CXX = $(GXX)
RM = rm -f
COPY = cp
COPY_R = cp -r
@@ -529,9 +527,9 @@
ifneq (,$(shell $(GXX) --version|grep 'g++.*4\.2\.'))
# OS X uses a buggy ancient version of gcc without fixes from even
# subsequent point releases of 4.2.
- CFOPTIMIZE := -O0
+ CFOPTIMIZE :=
else
- CFOPTIMIZE := -O2
+ CFOPTIMIZE :=
endif
endif
@@ -585,7 +583,7 @@
BUILD_LUA = yes
endif
else
- ifneq ($(shell $(PKGCONFIG) lua5.1 --exists || echo no),)
+ ifneq ($(shell $(PKGCONFIG) lua-5.1 --exists || echo no),)
ifneq ($(shell $(PKGCONFIG) lua --exists || echo no),)
BUILD_LUA = yes
else
@@ -596,13 +594,13 @@
endif
endif
else
- LUA_PACKAGE = lua5.1
+ LUA_PACKAGE = lua-5.1
endif
endif
endif
ifndef BUILD_LUA
ifndef LUA_PACKAGE
- LUA_PACKAGE = lua5.1
+ LUA_PACKAGE = lua-5.1
endif
INCLUDES_L += $(shell $(PKGCONFIG) $(LUA_PACKAGE) --cflags-only-I)
CFLAGS_L += $(shell $(PKGCONFIG) $(LUA_PACKAGE) --cflags-only-other)
@@ -754,7 +752,7 @@
DEFINES += -DWIZARD
endif
ifdef NO_OPTIMIZE
-CFOPTIMIZE := -O0
+CFOPTIMIZE :=
endif
ifdef PCH
@@ -878,7 +876,7 @@
INSTALL_FONTS += $(PROPORTIONAL_FONT)
endif
else
- SYS_PROPORTIONAL_FONT = $(shell dir=/usr/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_PROPORTIONAL_FONT)|head -n 1)
+ SYS_PROPORTIONAL_FONT = $(shell dir=%%LOCALBASE%%/lib/X11/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_PROPORTIONAL_FONT)|head -n 1)
ifeq (,$(SYS_PROPORTIONAL_FONT))
SYS_PROPORTIONAL_FONT = $(shell dir=/usr/local/share/fonts ; [ -d $$dir ] && find $$dir -iname $(OUR_PROPORTIONAL_FONT)|head -n 1)
endif
@@ -901,7 +899,7 @@
INSTALL_FONTS += $(MONOSPACED_FONT)
endif
else
- SYS_MONOSPACED_FONT = $(shell dir=/usr/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_MONOSPACED_FONT)|head -n 1)
+ SYS_MONOSPACED_FONT = $(shell dir=%%LOCALBASE%%/lib/X11/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_MONOSPACED_FONT)|head -n 1)
ifeq (,$(SYS_MONOSPACED_FONT))
SYS_MONOSPACED_FONT = $(shell dir=/usr/local/share/fonts; [ -d $$dir ] && find $$dir -iname $(OUR_MONOSPACED_FONT)|head -n 1)
endif
@@ -1091,7 +1089,7 @@
cmd-name.h
SRC_PKG_BASE := stone_soup
-SRC_VERSION := $(shell git describe --tags $(MERGE_BASE) 2>/dev/null || cat util/release_ver)
+SRC_VERSION := $(shell cat util/release_ver)
MAJOR_VERSION = $(shell echo "$(SRC_VERSION)"|sed -r 's/-.*//;s/^([^.]+\.[^.]+).*/\1/')
export SRC_VERSION