* Fix build [2] * Respect CXXFLAGS (this port is broken with -O, so add -O0 to disable it) * Fix and sort pkg-plist Submitted by: Dan Johansson <djodv97@student.vxu.se> [1], Miguel Mendez <flynn@energyhq.homeip.net> [2] PR: ports/41040
11 lines
460 B
Text
11 lines
460 B
Text
--- mk/nasm.mak.orig Fri Sep 20 17:54:48 2002
|
|
+++ mk/nasm.mak Fri Sep 20 17:55:06 2002
|
|
@@ -18,7 +18,7 @@
|
|
NASM.BIN = nasm
|
|
|
|
# NASM flags (well, PROC= is not quite useful (for now?))
|
|
-NASMFLAGS = -DOS=$(OS) -DCOMP=$(COMP) -DPROC=$(PROC) $(NASMFLAGS.SYSTEM)
|
|
+NASMFLAGS = -DOS=$(OS) -DCOMP=$(COMP) -DPROC=$(PROC) -f elf
|
|
|
|
# If shared libraries use position-independent code, tell NASM about that
|
|
ifneq ($(substr pic,$(CFLAGS.DLL))$(substr PIC,$(CFLAGS.DLL)),)
|