freebsd-ports/irc/ctrlproxy/files/patch-src_gnutls.c
Ashish SHUKLA 1ad295db1c - Fix building of port due to gnutls update which removes gcrypt support
- Update MASTER_SITES with updated location of distfiles
- Fix pkg-plist

PR:		ports/158978
2011-07-18 07:22:22 +00:00

23 lines
383 B
C

$FreeBSD$
--- src/gnutls.c.orig
+++ src/gnutls.c
@@ -18,7 +18,6 @@
#include <glib.h>
-#include <gcrypt.h>
#include <gnutls/gnutls.h>
#include <gnutls/x509.h>
@@ -452,9 +451,6 @@
static void
_gnutls_init (void)
{
- /* to disallow usage of the blocking /dev/random */
- gcry_control (GCRYCTL_ENABLE_QUICK_RANDOM, 0);
-
gnutls_global_init ();
gnutls_inited = TRUE;
}