freebsd-ports/print/py-reportlab/files/patch-docs-userguide-genuserguide.py
TAKATSU Tomonari 0cbe65e47c - Repocopy print/py-reportlab to print/py-reportlab1
to preserve version 1.x and to update to 3.0

  print/py-reportlab:
    - Update print/py-reportlab to 3.0 based on print/py-reportlab2
    - Support STAGEDIR
    - Use PYDISTUTILS_AUTOPLIST
      * Remove pkg-plist, accordingly
    - Set CONFLICTS
    - Add PORTSCOUT
    - Replace tab with a single space after WWW: in pkg-descr

  print/py-reportlab1:
    - Support STAGEDIR
    - Add PKGNAMESUFFIX not to duplicate ports with the same name
    - Set CONFLICTS
    - Use PYDISTUTILS_AUTOPLIST
      * Remove pkg-plist, accordingly
    - Make use of PORTDOCS
    - Set OPTIONS_DEFINE explicitly
    - Fix include statement
    - Make docs unconditional to stage
    - Replace tab with a single space after WWW: in pkg-descr

  print/py-reportlab2:
    - Update CONFLICTS
    - Set PORTSCOUT

  dependent ports:
    - Switch dependency from print/py-reportlab to print/py-reportlab1
      * biology/py-biopython
      * deskutils/gourmet
      * deskutils/griffith
      * games/pythonsudoku
      * misc/pdfmap
      * print/py-trml2pdf
      * www/py-satchmo

PR:		ports/186970
Submitted by:	tota (myself)
Approved by:	Muhammad Moinur Rahman (maintainer)
2014-02-25 12:44:10 +00:00

12 lines
471 B
Python

--- docs/userguide/genuserguide.py.orig 2014-02-14 23:22:37.000000000 +0900
+++ docs/userguide/genuserguide.py 2014-02-16 16:15:05.000000000 +0900
@@ -8,7 +8,8 @@
"""
def run(pagesize=None, verbose=0, outDir=None):
- import sys,os
+ import sys,os,site
+ site.addsitedir("%%STAGEDIR%%%%PYTHON_SITELIBDIR%%")
from reportlab.lib.utils import open_and_read, asUnicode
cwd = os.getcwd()
docsDir=os.path.dirname(os.path.dirname(sys.argv[0]) or cwd)