freebsd-ports/x11/tkgoodstuff/files/patch-aa
Satoshi Asami b601dc2412 Correctly spell variable name so this port actually compiles. Seems
like someone commited a port without testing again! :(
1997-11-15 11:14:49 +00:00

62 lines
2.1 KiB
Text

--- configure Thu Aug 7 12:49:27 1997
+++ configure Wed Aug 27 01:18:17 1997
@@ -540,29 +540,34 @@
# Find appropriate tclConfig.sh and
# recover information that Tcl computed with its configure script.
-TCLCONFIGSH=""
-for prefix in $dirlist; do
- if test -f $prefix/lib/tclConfig.sh; then
- TCLCONFIGSH=$prefix/lib/tclConfig.sh
- . $TCLCONFIGSH
- if test `expr \( $TCL_MAJOR_VERSION \< $TCLTK_MAJORNEEDED \) \| \( $TCL_MINOR_VERSION \< $TCLTK_MINORNEEDED \)` = 0
- then
- break
+if [ -z "$TCLCONFIGSH" ] ; then
+ TCLCONFIGSH=""
+ for prefix in $dirlist; do
+ if test -f $prefix/lib/tclConfig.sh; then
+ TCLCONFIGSH=$prefix/lib/tclConfig.sh
+ . $TCLCONFIGSH
+ if test `expr \( $TCL_MAJOR_VERSION \< $TCLTK_MAJORNEEDED \) \| \( $TCL_MINOR_VERSION \< $TCLTK_MINORNEEDED \)` = 0
+ then
+ break
+ fi
fi
- fi
-done
+ done
+fi
test -f "$TCLCONFIGSH" || abort "Can't find any tclConfig.sh"
+. $TCLCONFIGSH
if test `expr \( $TCL_MAJOR_VERSION \< $TCLTK_MAJORNEEDED \) \| \( $TCL_MINOR_VERSION \< $TCLTK_MINORNEEDED \)` = 1
then
abort "Need but can't find tclConfig.sh for Tcl ${TCLTK_MAJORNEEDED}.${TCLTK_MINORNEEDED} or later."
fi
echo "using $TCLCONFIGSH"
-TKCONFIGSH=${prefix}/lib/tkConfig.sh
-test -f "$TKCONFIGSH" || abort "Can't find any tkConfig.sh"
+if [ -z "$TKCONFIGSH" ] ; then
+ TKCONFIGSH=${prefix}/lib/tkConfig.sh
+ test -f "$TKCONFIGSH" || abort "Can't find any tkConfig.sh"
+fi
. $TKCONFIGSH
if test `expr \( $TK_MAJOR_VERSION \< $TCLTK_MAJORNEEDED \) \| \( $TK_MINOR_VERSION \< $TCLTK_MINORNEEDED \)` = 1
- then abort "Need but can't find tkConfig.sh for Tk ${TCLTK_MAJORNEEDED}.${TCLTK_MINORNEEDED} or later."
+ then abort "Need but can't find tkConfig.sh for Tk ${TCLTK_MAJORNEEDED}.${TCLTK_MINORNEEDED} or later."
fi
echo "using $TKCONFIGSH"
--- libs/Makefile.in Wed Aug 6 08:10:43 1997
+++ libs/Makefile.in Wed Aug 27 01:22:36 1997
@@ -28,7 +28,8 @@
SRCDIR = @srcdir@
CFLAGS = -O @TCL_DEFS@ @TK_DEFS@ -I$(SRCDIR) \
- -I$(TK_PREFIX)/include -I$(TK_PREFIX)/include/tcl \
+ -I$(TK_PREFIX)/include/tcl8.0 \
+ -I$(TK_PREFIX)/include/tk8.0 \
$(XINCLUDES)
INSTALL = @INSTALL@