7cb4e5ddf6
* Project is hosted on sourceforge, adjust MASTER_SITES * Add dependency on Gimp, cairo, gtk20, glib20, pango and atk. They are mandatory for 2.8.4 * Make Java dependency optional, 2.8.4 can survive without Java * Hook dependencies on the autotools, we need to recreate the autogenerated files because now we have changed the autotools source config files (configure.ac etc.) with the hope that our changes will be propagated upstream * Switch to USE_LDCONFIG PR: ports/108265 Submitted by: vd Approved by: cartola@openit.com.br (maintainer timeout)
21 lines
520 B
Text
21 lines
520 B
Text
--- m4/ax_check_java.m4.orig Wed Jan 17 11:23:05 2007
|
|
+++ m4/ax_check_java.m4 Wed Jan 17 11:25:08 2007
|
|
@@ -2,7 +2,7 @@
|
|
dnl Usage:
|
|
dnl AX_CHECK_JAVA
|
|
dnl Test for java, and defines
|
|
-dnl - JAVA_CFLAGS (compiler flags)
|
|
+dnl - JAVA_FLAGS (compiler flags)
|
|
dnl - LIB_JAVA (linker flags, stripping and path)
|
|
dnl prerequisites:
|
|
|
|
@@ -78,6 +78,9 @@
|
|
case "${target_os}" in
|
|
linux*)
|
|
java_extra_inc=linux
|
|
+ ;;
|
|
+ *freebsd*)
|
|
+ java_extra_inc=freebsd
|
|
;;
|
|
darwin*)
|
|
java_extra_inc=darwin
|