freebsd-ports/editors/nedit/files/patch-Makefile
2015-04-03 16:47:55 +00:00

23 lines
938 B
Text

--- Makefile.orig 2014-12-07 00:03:44.000000000 -0500
+++ Makefile 2015-03-30 08:28:03.000000000 -0400
@@ -17,6 +17,7 @@
@echo "Please specify target:"
@echo "(For example, type \"make linux\" for a Linux system.)"
@(cd makefiles && ls -C Makefile* | sed -e 's/Makefile.//g')
+ @(cd doc; $(MAKE) man)
.DEFAULT:
@- (cd Microline/XmL; if [ -f ../../makefiles/Makefile.$@ -a ! -f ./Makefile.$@ ];\
@@ -44,6 +45,12 @@
# that doesn't work since we require the user to specify the target. More
# thought is needed
+install::
+ (cd source; make -f Makefile.freebsd install)
+ ${INSTALL} ${COPY} -m 644 doc/nedit.man $(DESTDIR)${PREFIX}/man/man1/nedit.1
+ ${INSTALL} ${COPY} -m 644 doc/nc.man $(DESTDIR)${PREFIX}/man/man1/nclient.1
+ ${INSTALL} ${COPY} -m 644 NEdit.ad $(DESTDIR)${LOCALBASE}/lib/X11/app-defaults/NEdit.ad
+
clean:
(cd util; $(MAKE) -f Makefile.common clean)
(cd Xlt; $(MAKE) -f Makefile.common clean)