In recent c++ library (such as on 14.x), <experimental/filesystem>
header would be removed in favor of standard <filesystem>. Remove
check for the former and don't do weird stuff when
experimental/filesystem is not present.
This is similar to 092787dffe
for
games/stratagus
Reported by: pkg-fallout
11 lines
348 B
Text
11 lines
348 B
Text
--- CMakeLists.txt.orig 2022-08-10 18:15:26 UTC
|
|
+++ CMakeLists.txt
|
|
@@ -162,7 +162,7 @@ set(wartool_LIBS ${pudconvert_LIBS} ${PNG_LIBRARIES} $
|
|
|
|
if(WIN32 AND MSVC)
|
|
add_definitions(-D_CRT_SECURE_NO_WARNINGS -D_CRT_SECURE_NO_DEPRECATE=1)
|
|
-else()
|
|
+elseif(FALSE)
|
|
include(CheckCXXSourceCompiles)
|
|
set(FS_SRC "
|
|
#include <experimental/filesystem>
|