freebsd-ports/games/holotz-castle/files/patch-all
Pav Lucistnik e57e66b1e3 - Update to 1.3.8
PR:		ports/92237
Submitted by:	Pierre-Paul Lavoie <ppl@nbnet.nb.ca> (maintainer)
2006-01-24 17:20:27 +00:00

40 lines
1.8 KiB
Text

diff -ru JLib/JLib/Util/JFS.cpp holotz-castle-1.3.8-src/JLib/JLib/Util/JFS.cpp
--- JLib/JLib/Util/JFS.cpp Fri Jan 20 08:59:37 2006
+++ holotz-castle-1.3.8-src/JLib/JLib/Util/JFS.cpp Mon Jan 23 21:21:36 2006
@@ -886,8 +886,8 @@
s32 n, k;
// Si es un directorio lo importa recursivamente
- struct dirent64 **namelist;
- n = scandir64(filename, &namelist, 0, alphasort);
+ struct dirent **namelist;
+ n = scandir(filename, &namelist, 0, alphasort);
if (n < 0)
{
diff -ru JLib/Makefile holotz-castle-1.3.8-src/JLib/Makefile
--- JLib/Makefile Fri Jan 20 08:59:37 2006
+++ holotz-castle-1.3.8-src/JLib/Makefile Mon Jan 23 21:20:53 2006
@@ -19,7 +19,7 @@
endif
# Define -D_JLIB_DEBUG to debug JLib. Compile the app to debug also with this flag
-CFLAGS=-I. -O3 -ffast-math -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
+CFLAGS=-I$(X11BASE)/include -I. -O3 -ffast-math -fPIC -Wall -Wshadow `$(SDL_CONFIG) --cflags`
# Sample LDFLAGS for applications
# LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
diff -ru src/Makefile holotz-castle-1.3.8-src/src/Makefile
--- src/Makefile Fri Jan 20 08:59:38 2006
+++ holotz-castle-1.3.8-src/src/Makefile Mon Jan 23 21:12:33 2006
@@ -42,8 +42,8 @@
# Definir -D_JLIB_DEBUG para debug con JLib. Ponerlo también en el Makefile de JLib.
# Define -D_JLIB_DEBUG for JLib debug mode. Put it also in JLib's Makefile.
-CFLAGS=-I. -I../JLib -O3 -Wall -Werror -Wshadow $(CPU_OPTS) -ffast-math -c `$(SDL_CONFIG) --cflags`
-LDFLAGS=-L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
+CFLAGS=-I$(X11BASE)/include -I. -I../JLib -O3 -Wall -Werror -Wshadow $(CPU_OPTS) -ffast-math -c `$(SDL_CONFIG) --cflags`
+LDFLAGS=-L$(X11BASE)/lib -L. -ffast-math -lSDL_image -lSDL_ttf -lSDL_mixer `$(SDL_CONFIG) --libs`
JLib: