freebsd-ports/devel/cocktail/files/patch-specs-modula-wag-Makefile
Pav Lucistnik c0150116c3 Add cocktail, a set of program generators or compiler construction tools
for nearly all phases of a compiler. It has been developed until 1993
at the Karlsruhe research lab of GMD, the German National Research Center
for Information Technology.

PR:		ports/65164
Submitted by:	Willem Jan Withagen <wjw@withagen.nl>
2004-05-04 21:07:46 +00:00

41 lines
1.1 KiB
Text

--- ../../work/cocktail-9309//./specs/modula/wag/Makefile Tue Feb 15 14:29:10 1994
+++ ./specs/modula/wag/Makefile Wed Mar 31 23:13:13 2004
@@ -18,29 +18,30 @@
lpp -xzj minilax.pars;
minilax.rex: minilax.scan Scanner.rpp
- rpp < minilax.scan > minilax.rex;
+ $(RPP) < minilax.scan > minilax.rex;
Scanner.md Scanner.mi: minilax.rex
- rex -d minilax.rex;
+ $(REX) -d minilax.rex;
Parser.md Parser.mi: Parser.lalr
- lalr -d Parser.lalr;
+ $(LALR) -d Parser.lalr;
Tree.md Tree.mi: minilax.cg
- cg -dimRDIL minilax.cg;
+ $(CG) -dimRDIL minilax.cg;
Semantics.md Semantics.mi: minilax.cg
- cg -DIL minilax.cg;
+ $(CG) -DIL minilax.cg;
Tree.TS: minilax.cg
- echo SELECT AbstractSyntax Output | cat - minilax.cg | cg -4
+ echo SELECT AbstractSyntax Output | cat - minilax.cg | $(CG) -4
Types.md Types.mi: Types.puma Tree.TS
- puma -dipk Types.puma;
+ $(PUMA) -dipk Types.puma;
ICode.md ICode.mi: ICode.puma Tree.TS
- puma -di ICode.puma;
+ $(PUMA) -di ICode.puma;
clean:
rm -f Scanner.m? Parser.m? Tree.m? Semantics.m? Types.m? ICode.m? *.TS *.bak
rm -f core *.[dimor] _Debug minilax minilax.rex Parser.lalr Scanner.rpp
+.include "../../Makefile.inc"