freebsd-ports/mail/quickml/files/extra-patch-ruby19-config.rb
Steve Wills 11a42e9792 - Make patches for ruby19 environment
- Fix Makefile
- SUB_LIST: to work rc.d scripts proper.
- PLIST_SUB: to change pkg-plist based on Make variables.

PR:		ports/169345
Submitted by:	Masaki TAGAWA <masaki@club.kyutech.ac.jp>
Approved by:	maintainer timeout (yaizawa@2004.jukuin.keio.ac.jp, >3 weeks)
2012-07-22 14:04:11 +00:00

11 lines
397 B
Ruby

--- lib/quickml/config.rb.orig 2012-06-21 17:13:32.000000000 +0900
+++ lib/quickml/config.rb 2012-06-21 17:13:46.000000000 +0900
@@ -62,7 +62,7 @@
@confirm_ml_creation = (config[:confirm_ml_creation] or false)
instance_variables.each {|name|
- self.class.class_eval { attr_reader name.delete('@') }
+ self.class.class_eval { attr_reader name.to_s.delete('@') }
}
end