freebsd-ports/multimedia/ffmpeg-devel/files/patch-libavutil__bswap.h
Mario Sergio Fujikawa Ferreira 4bb41a8ba4 Update to cvs snapshot 2005112800: house the snapshot distinfo under
MASTER_SITE_LOCAL. Currently, ffmpeg cvs snapshot distribution
server is down.
2005-11-29 03:11:41 +00:00

21 lines
550 B
C

--- libavutil/bswap.h.orig Mon Nov 28 22:16:18 2005
+++ libavutil/bswap.h Mon Nov 28 22:21:22 2005
@@ -6,8 +6,18 @@
#ifndef __BSWAP_H__
#define __BSWAP_H__
+/* to detect __FreeBSD_version */
+#if (defined(__unix__) || defined(unix)) && !defined(USG)
+#include <sys/param.h>
+#endif
+
#ifdef HAVE_BYTESWAP_H
#include <byteswap.h>
+#elif (defined(__FreeBSD__) && __FreeBSD_version >= 500000)
+# include <sys/endian.h>
+# define bswap_16(x) bswap16(x)
+# define bswap_32(x) bswap32(x)
+# define bswap_64(x) bswap64(x)
#else
#ifdef ARCH_X86_64