freebsd-ports/cad/PrusaSlicer/files/patch-CMakeLists.txt
Dmitry Marakasov 16f08410fa - Update to 2.3.0 [1]
- Some port cleanup [2]
  - Whitespace fixes
  - Remove duplicate and unused depends
  - Add missing depends
  - Use WX_CONFIG properly
  - Support FHS
  - Switch to PORTDATA
  - Install .desktop files into proper location
  - Fix compatibility with 11.x

PR:		252611
Submitted by:	teodorsigaev@gmail.com (maintainer) [1], amdmi3 [2]
2021-01-15 00:24:11 +00:00

30 lines
1.5 KiB
Text

--- CMakeLists.txt.orig 2021-01-11 13:01:51 UTC
+++ CMakeLists.txt
@@ -3,6 +3,7 @@ project(PrusaSlicer)
include("version.inc")
include(GNUInstallDirs)
+add_compile_options(-DNDEBUG)
set(SLIC3R_RESOURCES_DIR "${CMAKE_CURRENT_SOURCE_DIR}/resources")
file(TO_NATIVE_PATH "${SLIC3R_RESOURCES_DIR}" SLIC3R_RESOURCES_DIR_WIN)
@@ -154,7 +155,7 @@ if (APPLE)
endif ()
endif ()
-if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
+if (CMAKE_SYSTEM_NAME STREQUAL "Linux" OR CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
find_package(PkgConfig REQUIRED)
if (CMAKE_VERSION VERSION_LESS "3.1")
@@ -513,8 +514,8 @@ elseif (SLIC3R_FHS)
# CMAKE_INSTALL_FULL_DATAROOTDIR: read-only architecture-independent data root (share)
set(SLIC3R_FHS_RESOURCES "${CMAKE_INSTALL_FULL_DATAROOTDIR}/PrusaSlicer")
install(DIRECTORY "${SLIC3R_RESOURCES_DIR}/" DESTINATION "${SLIC3R_FHS_RESOURCES}")
- install(FILES src/platform/unix/PrusaSlicer.desktop DESTINATION ${SLIC3R_FHS_RESOURCES}/applications)
- install(FILES src/platform/unix/PrusaGcodeviewer.desktop DESTINATION ${SLIC3R_FHS_RESOURCES}/applications)
+ install(FILES src/platform/unix/PrusaSlicer.desktop DESTINATION share/applications)
+ install(FILES src/platform/unix/PrusaGcodeviewer.desktop DESTINATION share/applications)
else ()
install(FILES src/platform/unix/PrusaSlicer.desktop DESTINATION ${CMAKE_INSTALL_PREFIX}/resources/applications)
install(FILES src/platform/unix/PrusaGcodeviewer.desktop DESTINATION ${CMAKE_INSTALL_PREFIX}/resources/applications)