the Tcl/Tk scripting language. The project is open-source (BSD license) and based upon the NG-Spice source code base with many improvements Features and Improvements - Fully Tcl scriptable - installs with 'package require spice' statement - Hspice syntax (SpicePP). - GUI interfaces, various (Tk). - SpiceWish (BLT graph widget) - BLT (tcl compatible) vectors for storage, manipulation and arithmetic upon Spice waveforms. - Xspice additions (Georgia Tech). - Trigger upon waveform events. - Spice 'simulator state' save and restore for rapid 'what-if' simulations (no longer need to re-simulate from the beginning each time a device value is changed). Author: Stefan Jones <stefan.jones@multigig.com> WWW: http://tclspice.sourceforge.net/ PR: ports/99399 Submitted by: Stanislav Sedov <ssedov@mbsd.msk.ru>
14 lines
444 B
Text
14 lines
444 B
Text
--- src/xspice/icm/Makefile.orig Sat Jun 24 05:04:12 2006
|
|
+++ src/xspice/icm/Makefile Sat Jun 24 05:04:39 2006
|
|
@@ -12,9 +12,9 @@
|
|
-include .deps/cm.P
|
|
-include .deps/dlmain.P
|
|
|
|
-UPMAKE = make -f $(TOPDIR)../Makefile TOPDIR=$(TOPDIR)../
|
|
+UPMAKE = gmake -f $(TOPDIR)../Makefile TOPDIR=$(TOPDIR)../
|
|
|
|
-MAKE = make -f $(TOPDIR)Makefile TOPDIR=$(TOPDIR)
|
|
+MAKE = gmake -f $(TOPDIR)Makefile TOPDIR=$(TOPDIR)
|
|
|
|
COMPILE = $(CC) $(INCLUDES) $(CFLAGS)
|
|
|