freebsd-ports/textproc/isearch/files/patch-Makefile
Dmitry Marakasov d008ed3cbb - Fix build with gcc4.2 and amd64: remove -fwritable-strings.
- Remove GNU_CONFIGURE since it was doing nothing: respect CXX CXXFLAGS.
- Clean some warnings related to deprecated C++ headers.
- Use %%DOCSDIR%% in pkg-plist

PR:		126441
Submitted by:	"Pedro F. Giffuni" <giffunip at tutopia dot com>
Approved by:	Paul Marquis <pmarquis at pobox dot com> (maintainer)
2008-09-02 20:39:26 +00:00

53 lines
1.3 KiB
Text

--- Makefile.orig 2000-10-12 15:55:56.000000000 -0500
+++ Makefile 2008-08-10 22:44:02.000000000 -0500
@@ -23,9 +23,9 @@
#
# Compiler
#
-CC=g++
+CC=${CXX}
-DTCC=g++
+DTCC=${CXX}
#CC=/sw/CenterLine/bin/CC
#
@@ -45,7 +45,7 @@
#
# for Linux
#
-CFLAGS=-O2 -DUNIX -fwritable-strings
+CFLAGS=-O2 -DUNIX ${CXXFLAGS}
#CFLAGS=-g -fwritable-strings -Wall -Wno-unused -DUNIX # -DVERBOSE -DDEBUG
#
@@ -76,8 +76,8 @@
#
# Where should I install executables (make install)?
#
-INSTALL=/usr/local/bin
-CGI_INSTALL=/home/httpd/cgi-bin
+INSTALL=${PREFIX}/bin
+CGI_INSTALL=/usr/local/www/cgi-bin
#
# Executables Directory
@@ -189,12 +189,12 @@
install:
@echo "*** Copying Isearch executables to $(INSTALL) ***"
- cp $(BIN_DIR)/Iindex $(INSTALL)
- cp $(BIN_DIR)/Isearch $(INSTALL)
- cp $(BIN_DIR)/Iutil $(INSTALL)
- cp $(BIN_DIR)/Iget $(INSTALL)
- cp $(BIN_DIR)/zsearch $(INSTALL)
- cp $(BIN_DIR)/zpresent $(INSTALL)
+ install -s $(BIN_DIR)/Iindex $(INSTALL)
+ install -s $(BIN_DIR)/Isearch $(INSTALL)
+ install -s $(BIN_DIR)/Iutil $(INSTALL)
+ install -s $(BIN_DIR)/Iget $(INSTALL)
+ install -s $(BIN_DIR)/zsearch $(INSTALL)
+ install -s $(BIN_DIR)/zpresent $(INSTALL)
@echo ""
@echo "To install Isearch-cgi, cd into the Isearch-cgi directory"
@echo "Then run the configure script"