freebsd-ports/sysutils/nfsping/files/patch-Makefile
Bryan Drewery 09c2bfc693 Add sysutils/nfsping
NFSping is a command line utility for measuring the response time of an NFS
server. It's basically a copy of the fping interface but doesn't share any code
with that project.

On modern NFS servers, the network stack and filesystem are often being run on
separate cores or even hardware components. This means in practise that a fast
ICMP ping response isn't indicative of how quickly the NFS filesystem is
responding. This tool more directly tests the responsiveness of the server's
operating system's NFS component.

WWW: https://github.com/mprovost/NFSping
2013-10-20 00:18:16 +00:00

38 lines
1.5 KiB
Text

--- ./Makefile.orig 2013-10-19 17:19:23.064145798 -0500
+++ ./Makefile 2013-10-19 17:19:37.904136233 -0500
@@ -3,27 +3,27 @@
CFLAGS=-Werror -g -I src -I.
nfsping: src/nfsping.c src/nfsping.h src/nfs_prot_clnt.c src/mount_clnt.c src/util.c src/rpc.c
- gcc ${CFLAGS} src/nfsping.c src/nfs_prot_clnt.c src/nfs_prot_xdr.c src/mount_clnt.c src/mount_xdr.c src/util.c src/rpc.c -o $@
+ $(CC) ${CFLAGS} src/nfsping.c src/nfs_prot_clnt.c src/nfs_prot_xdr.c src/mount_clnt.c src/mount_xdr.c src/util.c src/rpc.c -o $@
src/nfs_prot.h src/nfs_prot_clnt.c src/nfs_prot_svc.c src/nfs_prot_xdr.c: src/nfs_prot.x
- rpcgen -DWANT_NFS3 $<
+ cd src && rpcgen -DWANT_NFS3 `basename $<`
src/mount.h src/mount_clnt.c src/mount_svc.c src/mount_xdr.c: src/mount.x
- rpcgen -DWANT_NFS3 $<
+ cd src && rpcgen -DWANT_NFS3 `basename $<`
nfsmount: src/mount.c src/nfsping.h src/mount_clnt.c src/mount_xdr.c src/rpc.c
- gcc ${CFLAGS} $^ -o $@
+ $(CC) ${CFLAGS} $^ -o $@
nfsdf: src/df.c src/nfsping.h src/nfs_prot_clnt.c src/nfs_prot_xdr.c src/util.c
- gcc ${CFLAGS} $^ -o $@
+ $(CC) ${CFLAGS} $^ -o $@
nfsls: src/ls.c src/nfs_prot_clnt.c src/nfs_prot_xdr.c src/util.c src/rpc.c
- gcc ${CFLAGS} $^ -o $@
+ $(CC) ${CFLAGS} $^ -o $@
nfscat: src/cat.c src/nfs_prot_clnt.c src/nfs_prot_xdr.c src/util.c src/rpc.c
- gcc ${CFLAGS} $^ -o $@
+ $(CC) ${CFLAGS} $^ -o $@
tests: tests/util_tests
tests/util_tests: tests/util_tests.c tests/minunit.h src/util.c src/util.h
- gcc ${CFLAGS} tests/util_tests.c src/util.c -o $@
+ $(CC) ${CFLAGS} tests/util_tests.c src/util.c -o $@