freebsd-ports/net/nss_ldap/files/patch-configure.in
Florent Thoumie 17e01b4b86 Disable pthread_atfork detection. This fixes login issues on FreeBSD
7.2-RELEASE and possibly previous versions.

PR:		ports/133501
Submitted by:	Benjamin Lee <ben@b1c1l1.com>
Approved by:	maintainer timeout (4 weeks)
2009-05-06 10:09:55 +00:00

34 lines
1.1 KiB
Text

--- configure.in.orig 2007-10-29 06:30:12.000000000 -0700
+++ configure.in 2008-09-26 20:38:20.000000000 -0700
@@ -96,11 +96,15 @@
linux*) nss_ldap_so_LDFLAGS="-shared -Wl,-Bdynamic -Wl,--version-script,\$(srcdir)/exports.linux" ;;
*) nss_ldap_so_LDFLAGS="-shared -Wl,-Bdynamic" ;;
esac
+case "$target_os" in
+freebsd*) TARGET_OS=FreeBSD ;;
+esac
AM_CONDITIONAL(GCC, test "$GCC" = "yes")
AM_CONDITIONAL(GLIBC, test "$target_os" = "linux" -o "$target_os" = "linux-gnu")
AM_CONDITIONAL(AIX, test "$TARGET_OS" = AIX)
AM_CONDITIONAL(HPUX, test "$TARGET_OS" = HPUX)
+AM_CONDITIONAL(FreeBSD, test "$TARGET_OS" = FreeBSD)
AM_CONDITIONAL(USE_NATIVE_LINKER, test -n "$nss_ldap_so_LD")
@@ -152,7 +156,6 @@
aix*) AC_CHECK_HEADERS(irs.h usersec.h) ;;
hpux*) AC_CHECK_HEADERS(nsswitch.h) ;;
*) AC_CHECK_HEADERS(nss.h)
- AC_CHECK_HEADERS(nsswitch.h)
AC_CHECK_HEADERS(irs.h) ;;
esac
AC_CHECK_HEADERS(thread.h)
@@ -227,7 +230,6 @@
AC_CHECK_FUNCS(gethostbyname)
AC_CHECK_FUNCS(nsdispatch)
AC_CHECK_LIB(pthread_nonshared, main)
-AC_CHECK_FUNCS(pthread_atfork)
AC_CHECK_FUNCS(pthread_once)
AC_CHECK_FUNCS(ether_aton)
AC_CHECK_FUNCS(ether_ntoa)