48e19315db
After many years of development, PostgreSQL has become feature-complete in many areas. This release shows a targeted approach to adding features (e.g., authentication, monitoring, space reuse), and adds capabilities defined in the later SQL standards. The major areas of enhancement are: Windowing Functions Common Table Expressions and Recursive Queries Default and variadic parameters for functions Parallel Restore Column Permissions Per-database locale settings Improved hash indexes Improved join performance for EXISTS and NOT EXISTS queries Easier-to-use Warm Standby Automatic sizing of the Free Space Map Visibility Map (greatly reduces vacuum overhead for slowly-changing tables) Version-aware psql (backslash commands work against older servers) Support SSL certificates for user authentication Per-function runtime statistics Easy editing of functions in psql New contrib modules: pg_stat_statements, auto_explain, citext, btree_gin URL: http://www.postgresql.org/docs/8.4/interactive/release-8-4.html
11 lines
647 B
Text
11 lines
647 B
Text
--- src/backend/Makefile.orig 2009-07-07 15:58:33.000000000 +0200
|
|
+++ src/backend/Makefile 2009-07-07 15:58:57.000000000 +0200
|
|
@@ -107,6 +107,8 @@
|
|
# Update the commonly used headers before building the subdirectories
|
|
$(SUBDIRS:%=%-recursive): $(top_builddir)/src/include/parser/gram.h $(top_builddir)/src/include/utils/fmgroids.h $(top_builddir)/src/include/utils/probes.h
|
|
|
|
+symlinks: $(top_builddir)/src/include/parser/gram.h $(top_builddir)/src/include/utils/fmgroids.h $(top_builddir)/src/include/utils/probes.h
|
|
+
|
|
|
|
# The postgres.o target is needed by the rule in Makefile.global that
|
|
# creates the exports file when MAKE_EXPORTS = true.
|