freebsd-ports/devel/elfutils/files/patch-libdw_Makefile.am
Conrad Meyer 552479055e Add elfutils 0.163
Elfutils is a collection of utilities, including: stack (to show
backtraces); nm (for listing symbols from object files); size (for
listing the section sizes of an object or archive file); strip (for
discarding symbols); readelf (to see the raw ELF file structures);
elflint (to check for well-formed ELF files); and elfcompress (to
compress or decompress ELF sections).

It also provides libraries to allow other programs to manipulate ELF and
DWARF data.

WWW:	https://fedorahosted.org/elfutils/

Reviewed by:	bdrewery
Sponsored by:	EMC / Isilon Storage Division
Differential Revision:	https://reviews.freebsd.org/D7206
2016-07-13 17:48:54 +00:00

19 lines
802 B
Text

--- libdw/Makefile.am.orig 2015-06-10 19:44:33 UTC
+++ libdw/Makefile.am
@@ -105,14 +105,14 @@ am_libdw_pic_a_OBJECTS = $(libdw_a_SOURC
libdw_so_SOURCES =
libdw.so$(EXEEXT): $(srcdir)/libdw.map libdw_pic.a ../libdwelf/libdwelf_pic.a \
../libdwfl/libdwfl_pic.a ../libebl/libebl.a \
- ../libelf/libelf.so
+ ../libelf/libelf.so ../lib/libeu.a
# The rpath is necessary for libebl because its $ORIGIN use will
# not fly in a setuid executable that links in libdw.
$(LINK) -shared -o $@ -Wl,--soname,$@.$(VERSION),-z,defs \
-Wl,--enable-new-dtags,-rpath,$(pkglibdir) \
-Wl,--version-script,$<,--no-undefined \
-Wl,--whole-archive $(filter-out $<,$^) -Wl,--no-whole-archive\
- -ldl $(argp_LDADD) $(zip_LIBS)
+ $(argp_LDADD) $(zip_LIBS)
@$(textrel_check)
ln -fs $@ $@.$(VERSION)