freebsd-ports/japanese/mailman/files/patch-configure.in
TAKATSU Tomonari ac239c2b83 - mail/mailman [1]
* Add LICENSE section
  * Add CONFLICTS with japanese/mailman
  * Make use of SUB_FILES
  * Make use of PORTDOCS
  * Apply simple use of OPTIONS
  * Add WITHOUT_NLS knob to make portlint happier
  * Append "MTA = 'Postfix'" to mm_cfg.py.dist.in when defined
    both WITH_POSTFIX and WITH_INTEGRATION at the same time [3]
  * Bump PORTREVISION

- japanese/mailman [2]
  * Switch to Japanized mailman 2.1.14+j7 based on mail/mailman
  * Take maintainership
  * Add CONFLICTS with mail/mailman
  * Update pkg-descr
  * Set PORTEPOCH because 2.1.14.j7 is less than 2.1.14_6

PR:		ports/165404 (based on) [1], ports/165403 [2]
Submitted by:	tota (myself) [1] [2]
Suggested by:	Yoshito Takeuchi [3]
Approved by:	Sunagawa Koji (maintainer) [2]
Dedicated to:	Tokio Kikuchi
2012-03-04 06:00:38 +00:00

70 lines
1.5 KiB
Text

$FreeBSD: /tmp/pcvs/ports/japanese/mailman/files/patch-configure.in,v 1.1 2012-03-04 06:00:38 tota Exp $
Mailman tests for existence of users during configure -- unfortunately
this creates a problem; we create the users just before install.
We remove the testing part.
--- configure.in.orig 2011-12-11 16:56:23.000000000 +0900
+++ configure.in 2012-02-15 06:11:05.000000000 +0900
@@ -341,28 +341,7 @@
# $2 == user id to check for
AC_SUBST($1)
changequote(,)
-if test -z "$$1"
-then
- cat > conftest.py <<EOF
-import grp
-gid = ''
-for group in "$2".split():
- try:
- try:
- gname = grp.getgrgid(int(group))[0]
- break
- except ValueError:
- gname = grp.getgrnam(group)[0]
- break
- except KeyError:
- gname = ''
-fp = open("conftest.out", "w")
-fp.write("%s\n" % gname)
-fp.close()
-EOF
- $PYTHON conftest.py
- $1=`cat conftest.out`
-fi
+$1=$2
changequote([, ])
rm -f conftest.out conftest.py])
@@ -373,28 +352,7 @@
# $2 == user id to check for
AC_SUBST($1)
changequote(,)
-if test -z "$$1"
-then
- cat > conftest.py <<EOF
-import pwd
-uid = ''
-for user in "$2".split():
- try:
- try:
- uname = pwd.getpwuid(int(user))[0]
- break
- except ValueError:
- uname = pwd.getpwnam(user)[0]
- break
- except KeyError:
- uname = ''
-fp = open("conftest.out", "w")
-fp.write("%s\n" % uname)
-fp.close()
-EOF
- $PYTHON conftest.py
- $1=`cat conftest.out`
-fi
+$1=$2
changequote([, ])
rm -f conftest.out conftest.py])