37366074eb
Approved by: maintainer
93 lines
3.3 KiB
Text
93 lines
3.3 KiB
Text
--- rts/builds/dedicated/CMakeLists.txt 2014-10-07 16:09:51 -0400
|
|
+++ rts/builds/dedicated/CMakeLists.txt 2015-04-08 15:27:03 -0400
|
|
@@ -43,19 +43,6 @@
|
|
ENDIF (UNIX AND NOT MINGW)
|
|
|
|
-IF (MINGW OR APPLE)
|
|
- # Windows:
|
|
- # We still need these header files,
|
|
- # even if we are not going to link with SDL.
|
|
- # We have them available anyway (mingwlibs).
|
|
- # OS X:
|
|
- # Cocoa requires the SDL libary, whenever the SDL headers are used,
|
|
- # due to some #define magic, which is practically impossible to workaround.
|
|
- FIND_PACKAGE(SDL2 REQUIRED)
|
|
- INCLUDE_DIRECTORIES(${SDL2_INCLUDE_DIR})
|
|
-ELSE (MINGW OR APPLE)
|
|
- # Use a direct copy of the GL and SDL headers,
|
|
- # as these may not be available on headless systems.
|
|
- INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include/SDL2)
|
|
-ENDIF (MINGW OR APPLE)
|
|
+FIND_PACKAGE(SDL2 REQUIRED)
|
|
+INCLUDE_DIRECTORIES(${SDL2_INCLUDE_DIR})
|
|
|
|
|
|
--- rts/builds/headless/CMakeLists.txt 2014-10-07 16:09:51 -0400
|
|
+++ rts/builds/headless/CMakeLists.txt 2015-04-08 16:31:25 -0400
|
|
@@ -14,22 +14,7 @@
|
|
|
|
include_directories(${OPENAL_INCLUDE_DIR})
|
|
-IF (MINGW OR APPLE)
|
|
- # Windows:
|
|
- # We still need these header files,
|
|
- # even if we are not going to link with gl, glu and SDL.
|
|
- # We have them available anyway (mingwlibs).
|
|
- # OS X:
|
|
- # Cocoa requires the SDL libary, whenever the SDL headers are used,
|
|
- # due to some #define magic, which is practically impossible to workaround.
|
|
- FIND_PACKAGE(OpenGL REQUIRED)
|
|
- FIND_PACKAGE(SDL2 REQUIRED)
|
|
- INCLUDE_DIRECTORIES(${SDL2_INCLUDE_DIR})
|
|
-ELSE (MINGW OR APPLE)
|
|
- # Use a direct copy of the GL and SDL headers,
|
|
- # as these may not be available on headless systems.
|
|
- INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
|
|
- INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include/SDL2)
|
|
-ENDIF (MINGW OR APPLE)
|
|
|
|
+FIND_PACKAGE(SDL2 REQUIRED)
|
|
+INCLUDE_DIRECTORIES(${SDL2_INCLUDE_DIR})
|
|
|
|
# headlessstubs are our stubs that replace libGL, libGLU, libGLEW, libSDL (yes really!)
|
|
--- rts/lib/headlessStubs/CMakeLists.txt 2014-10-07 16:09:52 -0400
|
|
+++ rts/lib/headlessStubs/CMakeLists.txt 2015-04-08 14:40:20 -0400
|
|
@@ -7,16 +7,6 @@
|
|
)
|
|
|
|
-IF (WIN32)
|
|
- # We still need these header files,
|
|
- # even if we are not going to link with SDL.
|
|
- # We have them available anyway (mingwlibs).
|
|
- FIND_PACKAGE(SDL2 REQUIRED)
|
|
- INCLUDE_DIRECTORIES(${SDL2_INCLUDE_DIR})
|
|
-ELSE (WIN32)
|
|
- # Use a direct copy of the GL and SDL headers,
|
|
- # as these may not be available on headless systems.
|
|
- INCLUDE_DIRECTORIES(BEFORE ${CMAKE_SOURCE_DIR}/include)
|
|
- INCLUDE_DIRECTORIES(BEFORE ${CMAKE_SOURCE_DIR}/include/SDL2)
|
|
-ENDIF (WIN32)
|
|
+FIND_PACKAGE(SDL2 REQUIRED)
|
|
+INCLUDE_DIRECTORIES(${SDL2_INCLUDE_DIR})
|
|
|
|
ADD_LIBRARY(headlessStubs STATIC EXCLUDE_FROM_ALL ${headlessStubsSources})
|
|
--- tools/unitsync/CMakeLists.txt 2014-10-07 16:09:52 -0400
|
|
+++ tools/unitsync/CMakeLists.txt 2015-04-08 16:10:11 -0400
|
|
@@ -22,16 +22,6 @@
|
|
ENDIF (WIN32)
|
|
|
|
-IF (MINGW)
|
|
- # We still need these header files,
|
|
- # even if we are not going to link with SDL.
|
|
- # We have them available anyway (mingwlibs).
|
|
- FIND_PACKAGE(SDL2 REQUIRED)
|
|
- INCLUDE_DIRECTORIES(${SDL2_INCLUDE_DIR})
|
|
-ELSE (MINGW)
|
|
- # Use a direct copy of the GL and SDL headers,
|
|
- # as these may not be available on headless systems.
|
|
- INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include/SDL2)
|
|
-ENDIF (MINGW)
|
|
-
|
|
+FIND_PACKAGE(SDL2 REQUIRED)
|
|
+INCLUDE_DIRECTORIES(${SDL2_INCLUDE_DIR})
|
|
|
|
ADD_DEFINITIONS(-DUNITSYNC)
|