freebsd-ports/www/firefox15/files/patch-browser_app_mozilla.in
Michael Johnson 36353c589f - Update firefox to 1.5
- Add Makefile.common
  o A new build/install system for gecko ports, Makefile.common
    includes many generic routines and common tasks.
  o Fix ld-run-path in all gecko's by using -Wl,-rpath,${moz_libdir}
    thus removing the need to have a startup script for ports that
    depend on gecko. [2]
  o Use system libm, nss, nspr in all gecko ports

- Add bsd.gecko.mk
  o This is the predecessor to WITH_MOZILLA=[mozilla|firefox|...]
    with a more robust way of detecting a gecko a end user wishs to
    use.
  o bsd.gecko.mk abstracts the selection of gecko-based backends. It
    allows users and porters to support any available gecko backend
    without needing to build many conditional tests. ${USE_GECKO} is the
    list of backends that your port can handle, and ${GECKO} is set by
    bsd.gecko.mk to be the chosen backend. Users set ${WITH_GECKO} to the
    list of gecko backends they want on their system.

  Port Makefile example:

  USE_GECKO=firefox mozilla seamonkey thunderbird
  .include <bsd.port.pre.mk>
  .include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"

  End user example:
  WITH_GECKO=seamonkey firefox

  We highly recommend moving away from using WITH_MOZILLA and switching to
  USE/WITH_GECKO.

PR:		89052 [2]
Submitted by:	vs [2]
Obtained from:	www/firefox
Thanks to:	adamw, marcus, and mezz for ideas, bug squashing, and more
		sajd from irc.freenode.org/#FreeBSD-Gnome for
		 pointing out many bugs
2005-11-29 21:12:28 +00:00

125 lines
3.1 KiB
Text

--- browser/app/mozilla.in.orig Mon Apr 4 15:08:49 2005
+++ browser/app/mozilla.in Wed Jun 1 14:47:45 2005
@@ -49,51 +49,83 @@
## the mozilla-bin binary to work.
##
+#
+# MOZ_PIS, "Mozilla Plugable Init Scripts"
+# MOZ_PIS_ is the name space used
+# These variables and there meaning are specified in
+# mozilla/xpfe/bootstrap/init.d/README
moz_pis_startstop_scripts()
{
- MOZ_USER_DIR="%MOZ_USER_DIR%"
- # MOZ_PIS_ is the name space for "Mozilla Plugable Init Scripts"
- # These variables and there meaning are specified in
- # mozilla/xpfe/bootstrap/init.d/README
- MOZ_PIS_API=2
- MOZ_PIS_MOZBINDIR="${dist_bin}"
- MOZ_PIS_SESSION_PID="$$"
- MOZ_PIS_USER_DIR="${MOZ_USER_DIR}"
- export MOZ_PIS_API MOZ_PIS_MOZBINDIR MOZ_PIS_SESSION_PID MOZ_PIS_USER_DIR
-
- case "${1}" in
- "start")
- for curr_pis in "${dist_bin}/init.d"/S* "${HOME}/${MOZ_USER_DIR}/init.d"/S* ; do
- if [ -x "${curr_pis}" ] ; then
- case "${curr_pis}" in
- *.sh) . "${curr_pis}" ;;
- *) "${curr_pis}" "start" ;;
- esac
- fi
- done
- ;;
- "stop")
- for curr_pis in "${HOME}/${MOZ_USER_DIR}/init.d"/K* "${dist_bin}/init.d"/K* ; do
- if [ -x "${curr_pis}" ] ; then
- case "${curr_pis}" in
- *.sh) . "${curr_pis}" ;;
- *) "${curr_pis}" "stop" ;;
- esac
- fi
- done
- ;;
- *)
- echo 1>&2 "$0: Internal error in moz_pis_startstop_scripts."
- exit 1
- ;;
- esac
+ MOZ_PIS_API=2
+ MOZ_PIS_MOZBINDIR="${dist_bin}"
+ MOZ_PIS_SESSION_PID="$$"
+ MOZ_PIS_USER_DIR="${MOZ_USER_DIR}"
+ export MOZ_PIS_API MOZ_PIS_MOZBINDIR MOZ_PIS_SESSION_PID MOZ_PIS_USER_DIR
+
+ case "${1}" in
+ "start")
+ for curr_pis in "${MOZ_PIS_MOZBINDIR}/init.d"/S* \
+ "${HOME}/${MOZ_PIS_USER_DIR}/init.d"/S*; do
+ if [ -x "${curr_pis}" ]; then
+ case "${curr_pis}" in
+ *.sh)
+ . "${curr_pis}"
+ ;;
+ *)
+ ${curr_pis} "start"
+ ;;
+ esac
+ fi
+ done
+ ;;
+ "stop")
+ for curr_pis in "${MOZ_PIS_MOZBINDIR}/init.d"/K* \
+ "${HOME}/${MOZ_PIS_USER_DIR}/init.d"/K*; do
+ if [ -x "${curr_pis}" ]; then
+ case "${curr_pis}" in
+ *.sh)
+ . "${curr_pis}"
+ ;;
+ *)
+ ${curr_pis} "stop"
+ ;;
+ esac
+ fi
+ done
+ ;;
+ *)
+ echo "$0: Internal error in moz_pis_startstop_scripts." 1>&2
+ exit 1
+ ;;
+ esac
}
-#uncomment for debugging
+# uncomment for debugging
#set -x
-moz_libdir=%MOZAPPDIR%
-MRE_HOME=%MREDIR%
+#
+# variables
+#
+#location="new-tab"
+#MOZILLA_UILOCALE="en-US"
+#MOZILLA_UIREGION="US"
+
+#
+# working definitions
+#
+MOZ_USER_DIR="%MOZ_USER_DIR%"
+moz_libdir="%MOZAPPDIR%"
+MRE_HOME="%MREDIR%"
+
+debugging= # set the debugging level
+use_openFile="yes" # use openFile() for file/dir
+here=`pwd`
+
+if [ ! -d "${MRE_HOME}" ]; then
+ # use moz_libdir as MRE_HOME
+ MRE_HOME="${moz_libdir}"
+fi
+export MRE_HOME
# Use run-mozilla.sh in the current dir if it exists
# If not, then start resolving symlinks until we find run-mozilla.sh