freebsd-ports/devel/cocktail/files/patch-reuse-src-Makefile
Edwin Groothuis 8937ed4066 [PORT UPGRADE] devel/cocktail corrected for 64bits compilation
The orignal port only ran on i386, since there were some
	64bit conversion problems. The included tar file replaces
	the compete devel/cocktail tree currently in the ports tree.

(lots of patches!)

PR:		ports/71940
Submitted by:	Willem Jan Withagen <wjw@withagen.nl>
2004-12-15 04:05:34 +00:00

29 lines
745 B
Text

--- /usr/ports/devel/cocktail/work/cocktail-9309//./reuse/src/Makefile Tue Feb 15 14:27:25 1994
+++ ./reuse/src/Makefile Thu Aug 5 18:49:36 2004
@@ -10,11 +10,11 @@
all: $(MC)
MC: rSystem.o
- rm -f Main
+ -rm -f Main
echo p Main | mc
M2C: rSystem.o
- rm -f Main
+ -rm -f Main
for file in `ls *.md`; do ln $$file `basename $$file .md`.def; done
for file in `ls *.mi`; do ln $$file `basename $$file .mi`.mod; done
make Main -f MakefileM2C
@@ -45,10 +45,10 @@
lint -u *.c
CLEAN: clean
- rm -f *.[dimor] *.sym *.def *.mod
+ -rm -f *.[dimor] *.sym *.def *.mod
clean:
- rm -f *Drv.[dimor] *Drv.sym *Drv Main.[dimor] Main t *.bak
+ -rm -f *Drv.[dimor] *Drv.sym *Drv Main.[dimor] Main t *.bak
.c.o:
$(CC) $(CFLAGS) -c $*.c;