freebsd-ports/devel/cocktail/files/patch-rpp-m2c-Makefile
Edwin Groothuis 8937ed4066 [PORT UPGRADE] devel/cocktail corrected for 64bits compilation
The orignal port only ran on i386, since there were some
	64bit conversion problems. The included tar file replaces
	the compete devel/cocktail tree currently in the ports tree.

(lots of patches!)

PR:		ports/71940
Submitted by:	Willem Jan Withagen <wjw@withagen.nl>
2004-12-15 04:05:34 +00:00

55 lines
921 B
Text

--- /usr/ports/devel/cocktail/work/cocktail-9309//./rpp/m2c/Makefile Tue Feb 15 14:28:12 1994
+++ ./rpp/m2c/Makefile Thu Aug 5 18:48:26 2004
@@ -1,24 +1,19 @@
-BIN = $(HOME)/bin
-BIN = $(HOME)/bin
-OPT = -O
-CC = cc
- # C library (reuse)
-REUSE = ../../reuse/m2c
+.include "../../Makefile.inc"
- # C libraries
-CLIBS = $(REUSE)/libreuse.a
-
- # options for C compiler
-CFLAGS = -w -I$(REUSE) $(OPT)
-
-M2FLAGS = -c
+ROOTDIR = ../..
+CFLAGS += -I$(INCDIR)
+CLIBS += $(REUSELIB)
all: rpp
install: rpp
- install -c -s -m 755 rpp $(BIN)
+ install -c -s -m 755 rpp $(DESTBIN)
+clean:
+ -rm -f $(STDCLEAN)
+ -rm -f *.o
+ -rm -f rpp
# HEAD
@@ -42,18 +37,3 @@
Scanner.o \
$(CLIBS)
-# TAIL
-
-clean :
- rm -f core *.o
-
-.SUFFIXES: .md .mi .h .c .o
-
-.mi.c:
- mtc2 $(M2FLAGS) $*.mi;
-
-.md.h:
- mtc2 $(M2FLAGS) $*.md;
-
-.c.o:
- $(CC) $(CFLAGS) -c $*.c