25 lines
840 B
Text
25 lines
840 B
Text
|
|
$FreeBSD$
|
|
|
|
--- codecs/gsm/Makefile.orig Sun Apr 27 21:13:11 2003
|
|
+++ codecs/gsm/Makefile Fri Oct 17 11:59:00 2003
|
|
@@ -54,8 +54,8 @@
|
|
# CC = /usr/lang/acc
|
|
# CCFLAGS = -c -O
|
|
|
|
-CC = gcc -ansi -pedantic $(OPTIMIZE) -march=$(PROC) -fschedule-insns2 -fomit-frame-pointer
|
|
-CCFLAGS += -c -DNeedFunctionPrototypes=1 -finline-functions -funroll-loops -fPIC
|
|
+CC ?= gcc
|
|
+CCFLAGS += -c -DNeedFunctionPrototypes=1 -finline-functions -funroll-loops -fPIC -ansi -pedantic $(OPTIMIZE) -fschedule-insns2 -fomit-frame-pointer
|
|
|
|
LD = $(CC)
|
|
|
|
@@ -140,7 +140,7 @@
|
|
DEBUG = -DNDEBUG
|
|
######### Remove -DNDEBUG to enable assertions.
|
|
|
|
-CFLAGS = $(PG) $(CCFLAGS) $(SASR) $(DEBUG) $(MULHACK) $(FAST) \
|
|
+CFLAGS += $(PG) $(CCFLAGS) $(SASR) $(DEBUG) $(MULHACK) $(FAST) \
|
|
$(LTP_CUT) $(WAV49) $(K6OPT) $(CCINC) -I$(INC)
|
|
######### It's $(CC) $(CFLAGS)
|
|
|