freebsd-ports/net-mgmt/ehnt/files/patch-ehnt.h
Sergey A. Osokin 06a5a4da0e Fix signed int problem in display (when displaying very
active flows it is possible to overflow bytecount). [1]

Also: [2]
 o use DOCSDIR and DATADIR macros
 o move files from pkg-plist to Makefile
 o remove pkg-plist

Reported by:	Gleb Smirnoff <glebius at sell dot sick dot ru>
Submitted by:	Dmitry Morozovsky <marck at rinet dot ru> (maintainer) [1],
		osa [2]
Approved by:	maintainer
PR:		66936
2004-05-21 08:39:04 +00:00

14 lines
409 B
C

$FreeBSD$
--- ehnt.h.orig Thu Oct 4 22:18:29 2001
+++ ehnt.h Thu May 20 16:07:24 2004
@@ -93,7 +93,7 @@
int ProcessFlow(struct flow_ver5_rec *, struct in_addr *, struct ehnt_struct *);
int Init_ASN_Lookups(void);
char * ASN_Lookup(int);
-char * prettybytes(int);
+char * prettybytes(unsigned);
void DisplayReport(time_t, struct ehnt_data *);
/* these EM_ defines are for the mode config variable */