08a19a2887
- Allow to override a command passing to distutils using PYDISTUTILS_{CONFIGURE,BUILD,INSTALL}_TARGET [2] - Allow to specify BUILD/RUN dependency separatedly. [3] - Replace shell executions with regex replacement on bsd.python.mk. [3] - Remove thread serialization from socket.getaddrinfo() on FreeBSD 5.3 and later versions because we've got thread-safe implementation. [4] - Add a workaround to avoid curses.h problem of FreeBSD base. PR: 86685 [1] Submitted by: Soeren Straarup <xride@x12.dk> [1], lioux [2], vsevolod [3], sobomax [4] Obtained from: Python CVS [4]
13 lines
620 B
C
13 lines
620 B
C
--- Modules/socketmodule.c.orig Sun Oct 2 21:49:22 2005
|
|
+++ Modules/socketmodule.c Sun Oct 2 21:50:01 2005
|
|
@@ -142,7 +142,9 @@
|
|
|
|
/* On systems on which getaddrinfo() is believed to not be thread-safe,
|
|
(this includes the getaddrinfo emulation) protect access with a lock. */
|
|
-#if defined(WITH_THREAD) && (defined(__APPLE__) || defined(__FreeBSD__) || \
|
|
+#include <sys/param.h>
|
|
+#if defined(WITH_THREAD) && (defined(__APPLE__) || \
|
|
+ (defined(__FreeBSD__) && __FreeBSD_version+0 < 503000) || \
|
|
defined(__OpenBSD__) || defined(__NetBSD__) || !defined(HAVE_GETADDRINFO))
|
|
#define USE_GETADDRINFO_LOCK
|
|
#endif
|