d4e5177000
release announcement is here: http://lists.gnu.org/archive/html/qemu-devel/2009-12/msg02151.html Quoting from pkg-message: - kqemu is no longer supported in qemu upstream after the 0.11 branch was created, which means also not in this version. (Linux has moved on to kvm now for qemu(-like) virtualization needs, so if you want qemu to go faster and don't want to switch to virtualbox or stick to the older emulators/qemu port which is at 0.11.1 atm and as such still supports kqemu you should help getting the FreeBSD kvm port updated and completed: http://wiki.freebsd.org/FabioChecconi/PortingLinuxKVMToFreeBSD )
49 lines
1.4 KiB
Text
49 lines
1.4 KiB
Text
Index: qemu/Makefile
|
|
@@ -16,6 +16,8 @@
|
|
|
|
VPATH=$(SRC_PATH):$(SRC_PATH)/hw
|
|
|
|
+QEMU_CFLAGS+= -DSMBD_COMMAND=\"${LOCALBASE}/sbin/smbd\" -I${LOCALBASE}/include -DPREFIX=\"${PREFIX}\"
|
|
+
|
|
LIBS+=-lz $(LIBS_TOOLS)
|
|
|
|
ifdef BUILD_DOCS
|
|
Index: qemu/Makefile.target
|
|
@@ -6,6 +6,7 @@
|
|
TARGET_PATH=$(SRC_PATH)/target-$(TARGET_BASE_ARCH)
|
|
VPATH=$(SRC_PATH):$(TARGET_PATH):$(SRC_PATH)/hw
|
|
QEMU_CFLAGS+= -I.. -I$(TARGET_PATH) -DNEED_CPU_H
|
|
+QEMU_CFLAGS+= -DSMBD_COMMAND=\"${LOCALBASE}/sbin/smbd\" -I${LOCALBASE}/include -DPREFIX=\"${PREFIX}\"
|
|
|
|
ifdef CONFIG_USER_ONLY
|
|
# user emulator name
|
|
Index: qemu/net.h
|
|
@@ -99,12 +99,14 @@
|
|
int slirp_is_inited(void);
|
|
void net_client_check(void);
|
|
|
|
-#define DEFAULT_NETWORK_SCRIPT "/etc/qemu-ifup"
|
|
-#define DEFAULT_NETWORK_DOWN_SCRIPT "/etc/qemu-ifdown"
|
|
+#define DEFAULT_NETWORK_SCRIPT PREFIX "/etc/qemu-ifup"
|
|
+#define DEFAULT_NETWORK_DOWN_SCRIPT PREFIX "/etc/qemu-ifdown"
|
|
+#ifndef SMBD_COMMAND
|
|
#ifdef __sun__
|
|
#define SMBD_COMMAND "/usr/sfw/sbin/smbd"
|
|
#else
|
|
#define SMBD_COMMAND "/usr/sbin/smbd"
|
|
#endif
|
|
+#endif
|
|
|
|
#endif
|
|
Index: qemu/net/tap.h
|
|
@@ -29,8 +29,8 @@
|
|
#include "qemu-common.h"
|
|
#include "qemu-option.h"
|
|
|
|
-#define DEFAULT_NETWORK_SCRIPT "/etc/qemu-ifup"
|
|
-#define DEFAULT_NETWORK_DOWN_SCRIPT "/etc/qemu-ifdown"
|
|
+#define DEFAULT_NETWORK_SCRIPT PREFIX "/etc/qemu-ifup"
|
|
+#define DEFAULT_NETWORK_DOWN_SCRIPT PREFIX "/etc/qemu-ifdown"
|
|
|
|
int net_init_tap(QemuOpts *opts, Monitor *mon, const char *name, VLANState *vlan);
|
|
|