This is probably a conflagration of CMake, Qt and other updates all happening at once. In poudriere, build of databases/kexi fails with ld: error: undefined symbol: KReportGroupTracker::qt_metacast(char const*) >>> referenced by mocs_compilation.cpp >>> src/plugins/reports/CMakeFiles/kexi_reportplugin.dir/kexi_reportplugin_autogen/mocs_compilation.cpp.o:(KRScriptFunctions::qt_metacast(char const*)) The problem lies in textproc/kreport, which has a QObject-derived class with no out-of-line virtual methods, and no clear path to have moc called on it. This patch splits out the virtual destructor, adds a .cpp file containing it, and causes automoc to run normally on the class. This makes all the QObject machinery appear in the shared library, and kexi can use it.
21 lines
718 B
Text
21 lines
718 B
Text
--- src/CMakeLists.txt.orig 2020-06-04 20:16:17 UTC
|
|
+++ src/CMakeLists.txt
|
|
@@ -106,6 +106,7 @@ set(kreport_TARGET_INCLUDE_DIRS
|
|
|
|
if(KREPORT_SCRIPTING)
|
|
list(APPEND kreport_LIB_SRCS
|
|
+ renderer/scripting/KReportGroupTracker.cpp
|
|
renderer/scripting/KReportScriptHandler.cpp
|
|
renderer/scripting/KReportScriptConstants.cpp
|
|
renderer/scripting/KReportScriptDebug.cpp
|
|
@@ -131,10 +132,6 @@ if(KREPORT_SCRIPTING)
|
|
items/field/KReportScriptField.cpp
|
|
items/image/KReportScriptImage.cpp
|
|
items/text/KReportScriptText.cpp
|
|
- )
|
|
-
|
|
- qt_wrap_cpp(KReport kreport_LIB_SRCS
|
|
- renderer/scripting/KReportGroupTracker.h
|
|
)
|
|
|
|
list(APPEND kreport_INCLUDE_DIRS
|