freebsd-ports/games/duke3d/files/patch-aa
Pav Lucistnik 2dca57fcd0 - Update to newer snapshot
- Reclaim maintainership

PR:		ports/70771
Submitted by:	No Name <arundel@h3c.de>
2004-08-21 14:59:42 +00:00

24 lines
781 B
Text

--- source/buildengine/Makefile.orig Sat May 15 21:35:12 2004
+++ source/buildengine/Makefile Sat May 15 21:37:08 2004
@@ -106,7 +106,7 @@
SDL_LDFLAGS := $(shell sdl-config --libs)
endif
-CC = gcc
+#CC = gcc
# Uncomment to use the Intel compiler (v6.0)
# Note: Version 6.0 Build 020312Z fails to compile engine.c
@@ -200,9 +200,9 @@
ENGINEDIR = .
ASMFLAGS = -f $(ASMOBJFMT) $(ASMDEFS)
-LINKER = gcc
-CFLAGS += $(USE_ASM) -funsigned-char -O3 -DPLATFORM_UNIX -g -Wall $(SDL_CFLAGS) -fno-omit-frame-pointer
-LDFLAGS += -g $(SDL_LDFLAGS)
+LINKER = $(CC)
+CFLAGS += %%CFLAGS%% $(USE_ASM) -funsigned-char -DPLATFORM_UNIX -Wall $(SDL_CFLAGS) -fno-omit-frame-pointer
+LDFLAGS += -L%%X11BASE%%/lib $(SDL_LDFLAGS)
# Rules for turning source files into .o files
%.o: %.c