freebsd-ports/comms/openzwave/files/patch-cpp_build_Makefile
Kubilay Kocak e03cfd1ee4 comms/openzwave: Open-source interface to Z-Wave networks
Free software library that interfaces with selected Z-Wave PC controllers,
allowing anyone to create applications that manipulate and respond to
devices on a Z-Wave network, without requiring in-depth knowledge of the
Z-Wave protocol.

WWW: http://www.openzwave.net/

PR:		206526
Submitted by:	Johan Ström <johan stromnet se> (with changes)
2019-03-27 06:00:11 +00:00

23 lines
635 B
Text

# Allow DOXYGEN (DOCS) and DOT to be conditionally disabled
# TODO: Upstream
--- cpp/build/Makefile.orig 2019-03-27 04:09:23 UTC
+++ cpp/build/Makefile
@@ -204,7 +204,7 @@ $(top_builddir)/ozw_config: $(top_srcdir)/cpp/build/oz
< "$<" > "$@"
@chmod +x $(top_builddir)/ozw_config
-ifeq ($(DOT),)
+ifndef DOT
HAVE_DOT = -e 's|[@]HAVE_DOT@|NO|g'
else
HAVE_DOT = -e 's|[@]HAVE_DOT@|YES|g'
@@ -219,7 +219,7 @@ $(top_builddir)/Doxyfile: $(top_srcdir)/docs/Doxyfile.
-e 's|[@]VERSION@|$(VERSION).$(VERSION_REV)|g' \
< "$<" > "$@"
-ifeq ($(DOXYGEN),)
+ifndef DOXYGEN
doc:
$(warning Documentation not being built)
else