freebsd-ports/net/mad_fcl/files/patch-alclib_linux__ssm.h
Volker Stolz 9d11b20f6f - Bugfix to support Source Specific Multicast with KAME kernel
- Nuke pkg-plist while here

PR:		ports/69900
Submitted by:	Janos Mohacsi (maintainer)
2004-08-06 07:24:55 +00:00

32 lines
859 B
C

$FreeBSD$
--- alclib/linux_ssm.h.orig Fri Jul 30 14:15:54 2004
+++ alclib/linux_ssm.h Mon Aug 2 11:50:48 2004
@@ -33,12 +33,12 @@
struct ip_mreq_source {
struct in_addr imr_multiaddr; /* IP address of group */
- struct in_addr imr_interface; /* IP address of interface */
struct in_addr imr_sourceaddr; /* IP address of source */
+ struct in_addr imr_interface; /* IP address of interface */
};
-#define IP_ADD_SOURCE_MEMBERSHIP 39
-#define IP_DROP_SOURCE_MEMBERSHIP 40
+#define IP_ADD_SOURCE_MEMBERSHIP 25
+#define IP_DROP_SOURCE_MEMBERSHIP 26
#endif
@@ -54,8 +54,8 @@
struct sockaddr_storage gsr_source; /* source address */
};
-#define MCAST_JOIN_SOURCE_GROUP 46
-#define MCAST_LEAVE_SOURCE_GROUP 47
+#define MCAST_JOIN_SOURCE_GROUP 74
+#define MCAST_LEAVE_SOURCE_GROUP 75
#endif