freebsd-ports/games/falconseye/files/patch-sys_unix_Makefile_top
2014-04-13 17:11:21 +00:00

69 lines
1.9 KiB
Text

--- sys/unix/Makefile.top.orig 2001-06-24 18:57:24.000000000 +0200
+++ sys/unix/Makefile.top 2014-04-13 18:56:38.000000000 +0200
@@ -15,11 +15,10 @@
# make NetHack
#PREFIX = /usr
-PREFIX = $(shell pwd)/compiled
-GAME = nethack
+GAME = falconseye
# GAME = nethack.prg
-GAMEUID = games
-GAMEGRP = bin
+GAMEUID = root
+GAMEGRP = games
# Permissions - some places use setgid instead of setuid, for instance
# See also the option "SECURE" in include/config.h
@@ -36,12 +35,13 @@
# therefore there should not be anything in GAMEDIR that you want to keep
# (if there is, you'll have to do the installation by hand or modify the
# instructions)
-GAMEDIR = $(PREFIX)/games/lib/$(GAME)dir
+REALGAMEDIR = $(PREFIX)/share/$(GAME)dir
+GAMEDIR = $(DESTDIR)${REALGAMEDIR}
VARDIR = $(GAMEDIR)
-SHELLDIR = $(PREFIX)/games
+SHELLDIR = ${DESTDIR}$(PREFIX)/bin
# per discussion in Install.X11 and Install.Qt
-VARDATND =
+# VARDATND =
# VARDATND = x11tiles pet_mark.xbm
# VARDATND = x11tiles pet_mark.xbm rip.xpm
# for Atari/Gem
@@ -78,7 +78,7 @@
# in order to e.g. access the Xlib server. In particular, we need to
# setgid instead of setuid. Therefore we must also allow group writing
# for the files and directories.
-GAMEPERM = 02755
+GAMEPERM = 02555
FILEPERM = 0664
EXEPERM = 0755
DIRPERM = 0775
@@ -119,12 +119,15 @@
$(GAME):
( cd src ; $(MAKE) )
-all: $(GAME) Guidebook $(VARDAT) dungeon spec_levs check-dlb
+all: $(GAME) Guidebook recover $(VARDAT) dungeon spec_levs check-dlb
@echo "Done."
Guidebook:
( cd doc ; $(MAKE) Guidebook )
+recover:
+ ( cd util ; $(MAKE) recover )
+
manpages:
( cd doc ; $(MAKE) manpages )
@@ -201,7 +204,7 @@
$(MAKE) dofiles-jtp
cp src/$(GAME) $(GAMEDIR)
-rm -f $(SHELLDIR)/$(GAME)
- sed -e 's;/usr/games/lib/nethackdir;$(GAMEDIR);' \
+ sed -e 's;/usr/games/lib/nethackdir;$(REALGAMEDIR);' \
-e 's;HACKDIR/nethack;HACKDIR/$(GAME);' \
< sys/unix/nethack.sh \
> $(SHELLDIR)/$(GAME)