freebsd-ports/irc/ratbox-services/files/patch-Makefile.in
Beech Rintoul 8bf7d6ac01 - Update to 1.2.0
Some port changes include:
o Removed port dependency on patch files.
o Added LIB_DEPENDS for requiring pcre to build services.
o Added CONFIGURE_ENV options to help configure detect sqlite and pcre libs and header files.
o Added PERL dependency for database schema generation scripts on port installation.
o Added new Memoserv configure options.
o Restored MySQL database backend support.
o Fixed build error caused when building with 'NOPORTDOCS=yes'.

Brief list of some package changes:
o Multi-language support - Support for different language translations of services help files and
responses (currently not recommended in this release).
o Memoserv - A new service allowing usernames to send memos to each other.
o Service merging - Ability to merge services like banserv, jupeserv and watchserv into operserv.
o Regexp - Ability to add regular expression ban matches.
o Suspend - Ability to suspend users and channels.

PR:		ports/125035
Submitted by:	Lewis <moggie@elasticmind.net> (maintainer)
2008-07-02 22:28:13 +00:00

34 lines
1.3 KiB
Text

--- ./Makefile.in.orig 2008-02-17 15:33:40.000000000 +0000
+++ ./Makefile.in 2008-06-26 15:48:13.000000000 +0100
@@ -6,8 +6,8 @@
LIBS=@LIBS@
LDFLAGS=@LDFLAGS@
-SUBDIRS=@SQLITE_SUBDIR@ @PCRE_SUBDIR@ src help langs
-SUBDIRS_NOINSTALL=@SQLITE_SUBDIR@ src help langs
+SUBDIRS=src help langs
+SUBDIRS_NOINSTALL=src help langs
prefix=@prefix@
exec_prefix=@prefix@
@@ -38,20 +38,6 @@
done
install: build
- $(INSTALL) -m 750 -d $(DESTDIR)$(prefix)
- $(INSTALL) -m 750 -d $(DESTDIR)$(bindir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(sbindir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(sysconfdir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(includedir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(logdir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(rundir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(helpdir)
- $(INSTALL) -m 750 -d $(DESTDIR)$(includedir)
- $(INSTALL) -m 750 tools/ircd-shortcut.pl $(DESTDIR)$(bindir)
- $(INSTALL) -m 750 tools/dbupgrade.pl $(DESTDIR)$(bindir)
- $(INSTALL) -m 640 tools/definetolength.pl $(DESTDIR)$(bindir)
- $(INSTALL) -m 750 src/$(BIN) $(DESTDIR)$(sbindir)
- $(INSTALL) -m 640 doc/example.conf $(DESTDIR)$(sysconfdir)
$(INSTALL) -m 640 include/setup.h $(DESTDIR)$(includedir)
$(INSTALL) -m 640 include/rserv.h $(DESTDIR)$(includedir)
$(INSTALL) -m 640 include/channel.h $(DESTDIR)$(includedir)