8937ed4066
The orignal port only ran on i386, since there were some 64bit conversion problems. The included tar file replaces the compete devel/cocktail tree currently in the ports tree. (lots of patches!) PR: ports/71940 Submitted by: Willem Jan Withagen <wjw@withagen.nl>
36 lines
1.1 KiB
Text
36 lines
1.1 KiB
Text
--- /usr/ports/devel/cocktail/work/cocktail-9309//./front/doc/Makefile Tue Feb 15 14:23:21 1994
|
|
+++ ./front/doc/Makefile Thu Aug 5 18:48:59 2004
|
|
@@ -1,17 +1,18 @@
|
|
# $Id: Makefile,v 2.8 1993/08/24 13:19:11 grosch rel $
|
|
|
|
-LIB = $(HOME)/lib
|
|
+.include "../../Makefile.inc"
|
|
+ROOTDIR=../..
|
|
|
|
-install: bnf.cat lalr.cat bnf.syn lalr.syn $(LIB)/lalr
|
|
- install -c -m 644 bnf.cat $(LIB)/lalr
|
|
- install -c -m 644 lalr.cat $(LIB)/lalr
|
|
- install -c -m 644 bnf.syn $(LIB)/lalr
|
|
- install -c -m 644 lalr.syn $(LIB)/lalr
|
|
+install: bnf.cat lalr.cat bnf.syn lalr.syn $(DESTLIB)/lalr
|
|
+ install -c -m 644 bnf.cat $(DESTLIB)/lalr
|
|
+ install -c -m 644 lalr.cat $(DESTLIB)/lalr
|
|
+ install -c -m 644 bnf.syn $(DESTLIB)/lalr
|
|
+ install -c -m 644 lalr.syn $(DESTLIB)/lalr
|
|
|
|
# installation directories
|
|
|
|
-$(LIB)/lalr: $(LIB)
|
|
- sh -c "if test ! -d $(LIB)/lalr; then mkdir -p $(LIB)/lalr; else true; fi"
|
|
+$(DESTLIB)/lalr: $(DESTLIB)
|
|
+ sh -c "if test ! -d $(DESTLIB)/lalr; then mkdir -p $(DESTLIB)/lalr; else true; fi"
|
|
|
|
bnf.cat: bnf.1
|
|
nroff -man < bnf.1 | col > bnf.cat
|
|
@@ -24,4 +25,5 @@
|
|
troff -man lalr.1
|
|
|
|
clean:
|
|
- rm -f bnf.cat lalr.cat
|
|
+ -rm -f bnf.cat lalr.cat
|
|
+
|