8937ed4066
The orignal port only ran on i386, since there were some 64bit conversion problems. The included tar file replaces the compete devel/cocktail tree currently in the ports tree. (lots of patches!) PR: ports/71940 Submitted by: Willem Jan Withagen <wjw@withagen.nl>
64 lines
1.4 KiB
Text
64 lines
1.4 KiB
Text
--- /usr/ports/devel/cocktail/work/cocktail-9309//./reuse/c/Makefile Tue Feb 15 14:26:37 1994
|
|
+++ ./reuse/c/Makefile Thu Aug 5 18:49:32 2004
|
|
@@ -1,35 +1,31 @@
|
|
-LIB = $(HOME)/lib
|
|
-INCDIR = $(LIB)/include
|
|
-TARGET = SUN
|
|
-REUSE = libreuse.a
|
|
-OPT = -O
|
|
-UNIX = UNIX
|
|
-CFLAGS = $(OPT) -D$(UNIX) -D$(TARGET)
|
|
-CC = cc
|
|
-OBJS = rSystem.o General.o rMemory.o DynArray.o StringMem.o Idents.o Sets.o Time.o \
|
|
- Errors.o Positions.o Source.o
|
|
|
|
-# targets
|
|
+.include "../../Makefile.inc"
|
|
|
|
-all: $(TARGET)
|
|
+OBJS = rSystem.o General.o rMemory.o DynArray.o StringMem.o Idents.o \
|
|
+ Sets.o Time.o Errors.o Positions.o Source.o
|
|
|
|
-PCS10 PCS20: $(REUSE)
|
|
+# targets
|
|
|
|
-SUN: $(REUSE)
|
|
- ranlib $(REUSE)
|
|
+all: $(REUSE)
|
|
|
|
$(REUSE): $(OBJS)
|
|
ar ruc $(REUSE) $(OBJS)
|
|
-ranlib $(REUSE)
|
|
|
|
-install: $(TARGET)
|
|
- install -c -m 664 $(REUSE) $(LIB)
|
|
- -ranlib $(LIB)/$(REUSE)
|
|
- cp *.h $(INCDIR)
|
|
- chmod u+w,a+r $(INCDIR)/*.h
|
|
+install: $(REUSE)
|
|
+ install -c -m 664 $(REUSE) $(DESTLIB)
|
|
+ -ranlib $(DESTLIB)/$(REUSE)
|
|
+ cp *.h $(DESTINCDIR)
|
|
+ chmod u+w,a+r $(DESTINCDIR)/*.h
|
|
+
|
|
+clean: cleantest
|
|
+ -rm -f $(STDCLEAN)
|
|
+ -rm -f *.o *Drv
|
|
+ -rm -f $(REUSE)
|
|
+
|
|
+cleantest:
|
|
+ -rm -f rMemoryDrv DynArrDrv SetsDrv IdentsDrv StrMemDrv ErrorsDrv
|
|
|
|
-clean:
|
|
- rm -f *.o *Drv core
|
|
|
|
# test programs
|
|
|
|
@@ -73,7 +69,3 @@
|
|
ErrorsDrv.o: Errors.h Positions.h Sets.h Idents.h
|
|
Source.o: Source.h rSystem.h
|
|
|
|
-.SUFFIXES: .c .o
|
|
-
|
|
-.c.o:
|
|
- $(CC) $(CFLAGS) -c $*.c
|