freebsd-ports/databases/mysql80-server/files/patch-CMakeLists.txt
Mahdi Mokhtari dcc891e0be databases/mysql80-{client, server}: Update to latest release 8.0.14
This update (released on Jan 21st) includes:
Bugs Fixed:
  Important Change: Fix importing a dump from a MySQL 5.7 server 8.0 failure.
    (ER_WRONG_VALUE_FOR_VAR, when an unsupported [by 8.0] SQL mode was used).
    The behavior of the server in such circumstances now depends on the setting of the
    `pseudo_slave_mode` system variable.
    If this is false, the server rejects the mode setting with ER_UNSUPPORTED_SQL_MODE.
    Otherwise, server just gives a warning. (Bug #90337, Bug #27828236).

  InnoDB: Properly initialize the static thread-local 'tables' variable in
    the TempTable storage engine (on Solaris X86) was not properly initialized.
    (Bug #28987365)

  InnoDB: Fix incorrect lock order caused a deadlock when one thread attempted to
    drop a table while another created an encrypted tablespace. (Bug #28774259)

More info from upstream:
  https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-14.html

While here, Adapt some local patches with new upstream changes.

PR:		234984
Sponsored by:	The FreeBSD Foundation
2019-01-26 18:36:14 +00:00

35 lines
1.1 KiB
Text

--- CMakeLists.txt.orig 2019-01-21 19:00:53 UTC
+++ CMakeLists.txt
@@ -1045,7 +1045,6 @@ IF(UNIX)
ENDIF()
IF(NOT WITHOUT_SERVER)
- ADD_SUBDIRECTORY(testclients)
ADD_SUBDIRECTORY(sql)
ENDIF()
@@ -1054,8 +1053,6 @@ ENDIF()
ADD_SUBDIRECTORY(scripts)
IF(NOT WITHOUT_SERVER)
- ADD_SUBDIRECTORY(mysql-test)
- ADD_SUBDIRECTORY(mysql-test/lib/My/SafeProcess)
ADD_SUBDIRECTORY(support-files)
IF(EXISTS ${CMAKE_SOURCE_DIR}/internal/CMakeLists.txt)
ADD_SUBDIRECTORY(internal)
@@ -1152,6 +1149,7 @@ ENDIF()
#
# RPM installs documentation directly from the source tree
#
+IF(FALSE)
IF(NOT INSTALL_LAYOUT MATCHES "RPM")
INSTALL(FILES README LICENSE DESTINATION ${INSTALL_DOCREADMEDIR} COMPONENT Readme)
INSTALL(FILES ${CMAKE_BINARY_DIR}/Docs/INFO_SRC ${CMAKE_BINARY_DIR}/Docs/INFO_BIN DESTINATION ${INSTALL_DOCDIR})
@@ -1170,6 +1168,7 @@ IF(NOT INSTALL_LAYOUT MATCHES "RPM")
PATTERN "README.build" EXCLUDE
)
ENDIF()
+ENDIF()
# Now that we're done with all ADD_SUBDIRECTORY and thus all feature tests,
# we can safely enable ASan on Clang/Win32 if needed.