1f53fed603
and test it you need the following (5-CURRENT only, BTW): - fetch a patch for libvgl: http://people.freebsd.org/~sobomax/libvgl.patch, apply it, recompile/reinstall libvgl; - recompile/reinstall sdl-devel (configure script automatically detects if right version of libvgl is present); - set environment variable SDL_VIDEODRIVER=vgl; - ensure that you have VESA support compiled into kernel or loaded as a kld; - fire up your favourite SDL app ;).
328 lines
8.6 KiB
Text
328 lines
8.6 KiB
Text
|
|
$FreeBSD$
|
|
|
|
--- /dev/null Sun Jan 21 22:16:58 2001
|
|
+++ src/video/vgl/Makefile.in Sun Jan 21 22:06:20 2001
|
|
@@ -0,0 +1,322 @@
|
|
+# Makefile.in generated automatically by automake 1.4a from Makefile.am
|
|
+
|
|
+# Copyright (C) 1994, 1995-8, 1999 Free Software Foundation, Inc.
|
|
+# This Makefile.in is free software; the Free Software Foundation
|
|
+# gives unlimited permission to copy and/or distribute it,
|
|
+# with or without modifications, as long as this notice is preserved.
|
|
+
|
|
+# This program is distributed in the hope that it will be useful,
|
|
+# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
|
|
+# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
|
|
+# PARTICULAR PURPOSE.
|
|
+
|
|
+
|
|
+SHELL = @SHELL@
|
|
+
|
|
+srcdir = @srcdir@
|
|
+top_srcdir = @top_srcdir@
|
|
+VPATH = @srcdir@
|
|
+prefix = @prefix@
|
|
+exec_prefix = @exec_prefix@
|
|
+
|
|
+bindir = @bindir@
|
|
+sbindir = @sbindir@
|
|
+libexecdir = @libexecdir@
|
|
+datadir = @datadir@
|
|
+sysconfdir = @sysconfdir@
|
|
+sharedstatedir = @sharedstatedir@
|
|
+localstatedir = @localstatedir@
|
|
+libdir = @libdir@
|
|
+infodir = @infodir@
|
|
+mandir = @mandir@
|
|
+includedir = @includedir@
|
|
+oldincludedir = /usr/include
|
|
+
|
|
+DESTDIR =
|
|
+
|
|
+pkgdatadir = $(datadir)/@PACKAGE@
|
|
+pkglibdir = $(libdir)/@PACKAGE@
|
|
+pkgincludedir = $(includedir)/@PACKAGE@
|
|
+
|
|
+top_builddir = ../../..
|
|
+
|
|
+ACLOCAL = @ACLOCAL@
|
|
+AUTOCONF = @AUTOCONF@
|
|
+AUTOMAKE = @AUTOMAKE@
|
|
+AUTOHEADER = @AUTOHEADER@
|
|
+
|
|
+INSTALL = @INSTALL@
|
|
+INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
|
+INSTALL_DATA = @INSTALL_DATA@
|
|
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
|
|
+INSTALL_STRIP_FLAG =
|
|
+transform = @program_transform_name@
|
|
+
|
|
+NORMAL_INSTALL = :
|
|
+PRE_INSTALL = :
|
|
+POST_INSTALL = :
|
|
+NORMAL_UNINSTALL = :
|
|
+PRE_UNINSTALL = :
|
|
+POST_UNINSTALL = :
|
|
+host_alias = @host_alias@
|
|
+host_triplet = @host@
|
|
+ARCH = @ARCH@
|
|
+ARTSCCONFIG = @ARTSCCONFIG@
|
|
+AS = @AS@
|
|
+AUDIO_DRIVERS = @AUDIO_DRIVERS@
|
|
+AUDIO_SUBDIRS = @AUDIO_SUBDIRS@
|
|
+CC = @CC@
|
|
+CXX = @CXX@
|
|
+DLLTOOL = @DLLTOOL@
|
|
+ESD_CFLAGS = @ESD_CFLAGS@
|
|
+ESD_CONFIG = @ESD_CONFIG@
|
|
+ESD_LIBS = @ESD_LIBS@
|
|
+LIBTOOL = @LIBTOOL@
|
|
+LN_S = @LN_S@
|
|
+LT_AGE = @LT_AGE@
|
|
+LT_CURRENT = @LT_CURRENT@
|
|
+LT_RELEASE = @LT_RELEASE@
|
|
+LT_REVISION = @LT_REVISION@
|
|
+MAKEINFO = @MAKEINFO@
|
|
+NASM = @NASM@
|
|
+NASMFLAGS = @NASMFLAGS@
|
|
+OBJDUMP = @OBJDUMP@
|
|
+PACKAGE = @PACKAGE@
|
|
+RANLIB = @RANLIB@
|
|
+SDL_BINARY_AGE = @SDL_BINARY_AGE@
|
|
+SDL_CFLAGS = @SDL_CFLAGS@
|
|
+SDL_EXTRADIRS = @SDL_EXTRADIRS@
|
|
+SDL_EXTRALIBS = @SDL_EXTRALIBS@
|
|
+SDL_INTERFACE_AGE = @SDL_INTERFACE_AGE@
|
|
+SDL_LIBS = @SDL_LIBS@
|
|
+SDL_MAJOR_VERSION = @SDL_MAJOR_VERSION@
|
|
+SDL_MICRO_VERSION = @SDL_MICRO_VERSION@
|
|
+SDL_MINOR_VERSION = @SDL_MINOR_VERSION@
|
|
+SDL_RLD_FLAGS = @SDL_RLD_FLAGS@
|
|
+SDL_VERSION = @SDL_VERSION@
|
|
+SYSTEM_LIBS = @SYSTEM_LIBS@
|
|
+VERSION = @VERSION@
|
|
+VIDEO_DRIVERS = @VIDEO_DRIVERS@
|
|
+VIDEO_SUBDIRS = @VIDEO_SUBDIRS@
|
|
+
|
|
+noinst_LTLIBRARIES = libvideo_vgl.la
|
|
+libvideo_vgl_la_SOURCES = $(VGL_SRCS)
|
|
+
|
|
+# The SDL VGLlib video driver sources
|
|
+VGL_SRCS = SDL_vglvideo.h SDL_vglevents.c SDL_vglevents_c.h SDL_vglmouse.c SDL_vglmouse_c.h SDL_vglvideo.c
|
|
+
|
|
+mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
|
|
+CONFIG_CLEAN_FILES =
|
|
+LTLIBRARIES = $(noinst_LTLIBRARIES)
|
|
+
|
|
+
|
|
+DEFS = @DEFS@ -I. -I$(srcdir)
|
|
+CPPFLAGS = @CPPFLAGS@
|
|
+LDFLAGS = @LDFLAGS@
|
|
+LIBS = @LIBS@
|
|
+X_CFLAGS = @X_CFLAGS@
|
|
+X_LIBS = @X_LIBS@
|
|
+X_EXTRA_LIBS = @X_EXTRA_LIBS@
|
|
+X_PRE_LIBS = @X_PRE_LIBS@
|
|
+libvideo_vgl_la_LDFLAGS =
|
|
+libvideo_vgl_la_LIBADD =
|
|
+libvideo_vgl_la_OBJECTS = SDL_vglevents.lo SDL_vglmouse.lo \
|
|
+SDL_vglvideo.lo
|
|
+CFLAGS = @CFLAGS@
|
|
+COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
|
+LTCOMPILE = $(LIBTOOL) --mode=compile $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
|
|
+CCLD = $(CC)
|
|
+LINK = $(LIBTOOL) --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
|
|
+DIST_COMMON = Makefile.am Makefile.in
|
|
+
|
|
+
|
|
+DISTFILES = $(DIST_COMMON) $(SOURCES) $(HEADERS) $(TEXINFOS) $(EXTRA_DIST)
|
|
+
|
|
+TAR = gtar
|
|
+GZIP_ENV = --best
|
|
+SOURCES = $(libvideo_vgl_la_SOURCES)
|
|
+OBJECTS = $(libvideo_vgl_la_OBJECTS)
|
|
+
|
|
+all: all-redirect
|
|
+.SUFFIXES:
|
|
+.SUFFIXES: .S .c .lo .o .s
|
|
+$(srcdir)/Makefile.in: Makefile.am $(top_srcdir)/configure.in $(ACLOCAL_M4)
|
|
+ cd $(top_srcdir) && $(AUTOMAKE) --foreign --include-deps src/video/vgl/Makefile
|
|
+
|
|
+Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
|
|
+ cd $(top_builddir) \
|
|
+ && CONFIG_FILES=$(subdir)/$@ CONFIG_HEADERS= $(SHELL) ./config.status
|
|
+
|
|
+
|
|
+mostlyclean-noinstLTLIBRARIES:
|
|
+
|
|
+clean-noinstLTLIBRARIES:
|
|
+ -test -z "$(noinst_LTLIBRARIES)" || rm -f $(noinst_LTLIBRARIES)
|
|
+
|
|
+distclean-noinstLTLIBRARIES:
|
|
+
|
|
+maintainer-clean-noinstLTLIBRARIES:
|
|
+
|
|
+.c.o:
|
|
+ $(COMPILE) -c $<
|
|
+
|
|
+.s.o:
|
|
+ $(COMPILE) -c $<
|
|
+
|
|
+.S.o:
|
|
+ $(COMPILE) -c $<
|
|
+
|
|
+mostlyclean-compile:
|
|
+ -rm -f *.o core *.core
|
|
+
|
|
+clean-compile:
|
|
+
|
|
+distclean-compile:
|
|
+ -rm -f *.tab.c
|
|
+
|
|
+maintainer-clean-compile:
|
|
+
|
|
+.c.lo:
|
|
+ $(LIBTOOL) --mode=compile $(COMPILE) -c $<
|
|
+
|
|
+.s.lo:
|
|
+ $(LIBTOOL) --mode=compile $(COMPILE) -c $<
|
|
+
|
|
+.S.lo:
|
|
+ $(LIBTOOL) --mode=compile $(COMPILE) -c $<
|
|
+
|
|
+mostlyclean-libtool:
|
|
+ -rm -f *.lo
|
|
+
|
|
+clean-libtool:
|
|
+ -rm -rf .libs _libs
|
|
+
|
|
+distclean-libtool:
|
|
+
|
|
+maintainer-clean-libtool:
|
|
+
|
|
+libvideo_vgl.la: $(libvideo_vgl_la_OBJECTS) $(libvideo_vgl_la_DEPENDENCIES)
|
|
+ $(LINK) $(libvideo_vgl_la_LDFLAGS) $(libvideo_vgl_la_OBJECTS) $(libvideo_vgl_la_LIBADD) $(LIBS)
|
|
+
|
|
+tags: TAGS
|
|
+
|
|
+ID: $(HEADERS) $(SOURCES) $(LISP)
|
|
+ list='$(SOURCES) $(HEADERS)'; \
|
|
+ unique=`for i in $$list; do echo $$i; done | \
|
|
+ awk ' { files[$$0] = 1; } \
|
|
+ END { for (i in files) print i; }'`; \
|
|
+ here=`pwd` && cd $(srcdir) \
|
|
+ && mkid -f$$here/ID $$unique $(LISP)
|
|
+
|
|
+TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) $(LISP)
|
|
+ tags=; \
|
|
+ here=`pwd`; \
|
|
+ list='$(SOURCES) $(HEADERS)'; \
|
|
+ unique=`for i in $$list; do echo $$i; done | \
|
|
+ awk ' { files[$$0] = 1; } \
|
|
+ END { for (i in files) print i; }'`; \
|
|
+ test -z "$(ETAGS_ARGS)$$unique$(LISP)$$tags" \
|
|
+ || (cd $(srcdir) && etags $(ETAGS_ARGS) $$tags $$unique $(LISP) -o $$here/TAGS)
|
|
+
|
|
+mostlyclean-tags:
|
|
+
|
|
+clean-tags:
|
|
+
|
|
+distclean-tags:
|
|
+ -rm -f TAGS ID
|
|
+
|
|
+maintainer-clean-tags:
|
|
+
|
|
+distdir = $(top_builddir)/$(PACKAGE)-$(VERSION)/$(subdir)
|
|
+
|
|
+subdir = src/video/vgl
|
|
+
|
|
+distdir: $(DISTFILES)
|
|
+ @for file in $(DISTFILES); do \
|
|
+ d=$(srcdir); \
|
|
+ if test -d $$d/$$file; then \
|
|
+ cp -pr $$d/$$file $(distdir)/$$file; \
|
|
+ else \
|
|
+ test -f $(distdir)/$$file \
|
|
+ || ln $$d/$$file $(distdir)/$$file 2> /dev/null \
|
|
+ || cp -p $$d/$$file $(distdir)/$$file || :; \
|
|
+ fi; \
|
|
+ done
|
|
+info-am:
|
|
+info: info-am
|
|
+dvi-am:
|
|
+dvi: dvi-am
|
|
+check-am: all-am
|
|
+check: check-am
|
|
+installcheck-am:
|
|
+installcheck: installcheck-am
|
|
+install-exec-am:
|
|
+install-exec: install-exec-am
|
|
+
|
|
+install-data-am:
|
|
+install-data: install-data-am
|
|
+
|
|
+install-am: all-am
|
|
+ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
|
|
+install: install-am
|
|
+uninstall-am:
|
|
+uninstall: uninstall-am
|
|
+all-am: Makefile $(LTLIBRARIES)
|
|
+all-redirect: all-am
|
|
+install-strip:
|
|
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_STRIP_FLAG=-s install
|
|
+installdirs:
|
|
+
|
|
+
|
|
+mostlyclean-generic:
|
|
+
|
|
+clean-generic:
|
|
+
|
|
+distclean-generic:
|
|
+ -rm -f Makefile $(CONFIG_CLEAN_FILES)
|
|
+ -rm -f config.cache config.log stamp-h stamp-h[0-9]*
|
|
+
|
|
+maintainer-clean-generic:
|
|
+mostlyclean-am: mostlyclean-noinstLTLIBRARIES mostlyclean-compile \
|
|
+ mostlyclean-libtool mostlyclean-tags \
|
|
+ mostlyclean-generic
|
|
+
|
|
+mostlyclean: mostlyclean-am
|
|
+
|
|
+clean-am: clean-noinstLTLIBRARIES clean-compile clean-libtool \
|
|
+ clean-tags clean-generic mostlyclean-am
|
|
+
|
|
+clean: clean-am
|
|
+
|
|
+distclean-am: distclean-noinstLTLIBRARIES distclean-compile \
|
|
+ distclean-libtool distclean-tags distclean-generic \
|
|
+ clean-am
|
|
+ -rm -f libtool
|
|
+
|
|
+distclean: distclean-am
|
|
+
|
|
+maintainer-clean-am: maintainer-clean-noinstLTLIBRARIES \
|
|
+ maintainer-clean-compile maintainer-clean-libtool \
|
|
+ maintainer-clean-tags maintainer-clean-generic \
|
|
+ distclean-am
|
|
+ @echo "This command is intended for maintainers to use;"
|
|
+ @echo "it deletes files that may require special tools to rebuild."
|
|
+
|
|
+maintainer-clean: maintainer-clean-am
|
|
+
|
|
+.PHONY: mostlyclean-noinstLTLIBRARIES distclean-noinstLTLIBRARIES \
|
|
+clean-noinstLTLIBRARIES maintainer-clean-noinstLTLIBRARIES \
|
|
+mostlyclean-compile distclean-compile clean-compile \
|
|
+maintainer-clean-compile mostlyclean-libtool distclean-libtool \
|
|
+clean-libtool maintainer-clean-libtool tags mostlyclean-tags \
|
|
+distclean-tags clean-tags maintainer-clean-tags distdir info-am info \
|
|
+dvi-am dvi check check-am installcheck-am installcheck install-exec-am \
|
|
+install-exec install-data-am install-data install-am install \
|
|
+uninstall-am uninstall all-redirect all-am all installdirs \
|
|
+mostlyclean-generic distclean-generic clean-generic \
|
|
+maintainer-clean-generic clean mostlyclean distclean maintainer-clean
|
|
+
|
|
+
|
|
+# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
|
+# Otherwise a system limit (for SysV at least) may be exceeded.
|
|
+.NOEXPORT:
|