freebsd-ports/math/boolector/files/patch-CMakeLists.txt
Yuri Victorovich edeae32693 math/boolector: Update 3.0.0-239 -> 3.1.0
Reported by:	portscout
2019-12-04 07:18:01 +00:00

29 lines
709 B
Text

--- CMakeLists.txt.orig 2019-12-02 22:50:20 UTC
+++ CMakeLists.txt
@@ -434,20 +434,24 @@ configure_file(
# Regression tests
# Get and configure google test
+if (BUILD_TESTING)
include(cmake/googletest.cmake)
fetch_googletest(
${PROJECT_SOURCE_DIR}/cmake
${PROJECT_BINARY_DIR}/googletest
)
-enable_testing()
+ enable_testing()
+endif(BUILD_TESTING)
#-----------------------------------------------------------------------------#
# Source directories
include_directories(src ${CMAKE_CURRENT_BINARY_DIR}/src)
add_subdirectory(src)
-add_subdirectory(test)
+if (BUILD_TESTING)
+ add_subdirectory(test)
+endif(BUILD_TESTING)
if(PYTHON)
add_subdirectory(src/api/python)
endif()