freebsd-ports/net/ladvd/Makefile
Philip M. Gollucci 02afb3ef23 - update to 0.8 [1]
- does not build on !i386
    CFLAGS+= -fPIC doesn't fix it

PR:             ports/135966
Submitted by:   Sten Spans <sten@blinkenlights.nl> (maintainer)
2009-06-23 20:09:31 +00:00

38 lines
789 B
Makefile

# New ports collection makefile for: ladvd
# Date Created: 27 Jul 2008
# Whom: sten@blinkenlights.nl
#
# $FreeBSD$
#
PORTNAME= ladvd
PORTVERSION= 0.8
CATEGORIES= net
MASTER_SITES= http://blinkenlights.nl/software/ladvd/
MAINTAINER= sten@blinkenlights.nl
COMMENT= A minimal CDP/LLDP sender
LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
ONLY_FOR_ARCHS= i386
GNU_CONFIGURE= yes
PORTDOCS= *
MAN8= ladvd.8
USE_RC_SUBR+= ladvd
SUB_FILES= pkg-message pkg-install
post-patch:
.if defined(NOPORTDOCS)
@@${REINPLACE_CMD} 's|install-data-am: install-dist_docDATA|install-data-am:|' \
${WRKSRC}/doc/Makefile.in
.endif
post-install:
@${ECHO} "==> Creating custom user to run ladvd..."
@${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>